Bug 303131 - yum-cron replaces CentOS package
yum-cron replaces CentOS package
Status: CLOSED RAWHIDE
Product: Fedora EPEL
Classification: Fedora
Component: yum-cron (Show other bugs)
el5
All Linux
high Severity low
: ---
: ---
Assigned To: Habig, Alec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 10:19 EDT by Thorsten Leemhuis
Modified: 2007-12-05 09:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 03:42:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2007-09-24 10:19:30 EDT
Description of problem:
EPEL5-testing contains a yum-cron package which replaces the package with the
same name from CentOS-base. As we try to not conflict with CentOS-base, thus we
should go the same route as we did for yum in EPEL4 -- ship the CentOS package
with a lower EVR; then users that want to use the package on RHEL5 can use it
while we don't disturb CenOS.

For a discussion of the problem see
https://www.redhat.com/archives/epel-devel-list/2007-September/msg00012.html

Would that be fine for you?
Comment 1 Habig, Alec 2007-09-24 11:02:09 EDT
Sounds good in principle.  Just want to be clear on the details: by lower EVR
you mean the version-release numbering, or is there something more subtle?

The only other downstream distribution I know of is Scientific Linux, and there
the equivalent package is called autoyum, so should be no collision there.
Comment 2 Habig, Alec 2007-09-29 13:03:18 EDT
Got the CentOS package downloaded, and it's the same one as I made in response
to bug 212507.  The current Fedora/EPEL yum-cron is that first RPM made
compliant to Fedora packaging standards and with a few improvements.

I've contacted the CentOS maintainer to see if he agrees, but it seems to make
sense that the old version in CentOS be superseded by the newer and actively
maintained version.  Not that the package is very complicated, but there is some
benefit in the newer version.
Comment 3 R P Herrold 2007-10-01 21:47:28 EDT
Just for my edification, whom do you believe the maintainer to be?  I do not see
that 212507 is all that applicable, although yum-updatesd is probable
daemon-spawn  ;)

-- Russ Herrold, of CentOS
Comment 4 Thorsten Leemhuis 2007-10-02 00:51:58 EDT
(In reply to comment #3)
> Just for my edification, whom do you believe the maintainer to be? 

For yum-cron? The assigne (Habig, Alec); he told me he's in contact with the
CentOS maintainer of yum-cron to resolve this issue. I was told it seems the
yum-cron in EPEL has some bugfixes that might be interesting for CentOS. Maybe
Alec and the CentOS maintainer can work together with this (then the EPEL
package should of course like yum in EPEL4 be shipped with a lower EVR in EPEL
again)
Comment 5 R P Herrold 2007-10-02 10:30:22 EDT
Leemhuis, I am missing something - I understand, and I assume you do, that Habig
covers the Red Hat/Fedora EPEL side.  Thus the Red Hat Bugzilla assignment.  

We at CentOS do not carry a 'yum-cron' component per se (I have maintenance
rights on the CentOS tracker, and have just looked to reconfirm this); the
closest default assignment on yum matters in the CentOS tracker refers to a
person in travel status.

I do not see a name for the CentOS side, so that I can verify his belief.  If
you know, say so; if not, please don't toss in side issues.  As yum is and has
been CentOS updater from day one, and the yum maintainer formerly at Duke has
been involved in the decisions by CentOS on what we carry, in channels not
visible to you, I rather think EPEL is on a road to a collision in your fork
without visibility to the proper persons.
Comment 6 Habig, Alec 2007-10-02 12:25:25 EDT
"in contact with" is too strong a statement, I sent email off into the ether to
the guy listed in the CentOS yum-cron rpm, Karanbir Singh.  No reply yet though.
 That rpm is the one discussed in the email thread in the first comment above.

Simply making the Fedora yum-cron a lower version number than the CentOS one
doesn't make sense, though, since the CentOS one really is simply an older
version of the one in EPEL.
Comment 7 Thorsten Leemhuis 2007-10-04 13:35:20 EDT
(In reply to comment #5 from R P Herrold)
> Leemhuis, I am missing something - I understand, and I assume you do, that Habig
> covers the Red Hat/Fedora EPEL side.  Thus the Red Hat Bugzilla assignment.  

Alec is the maintainer of yum-cron -- I'm just one of those that takes care of
EPEL would like to see him solve the isse. As quickly if possible and it should
not enter the stable EPEL repo in its current state.

But I don't tell Alec how to solve the issue. He has mentioned something that
sounded like a good point: get a yum-cron in EPEL for those on RHEL that want
it. Get the same version in CentOS, as that's the EPEL one seems to contain
bugfixes that might be of interest for CentOS.
Comment 8 Thorsten Leemhuis 2007-12-03 10:53:07 EST
z00dax, thx for making sure yum-cron-0.6 made it into CentOS 5.1; that should
resolve this issue.

The ENVR from the centos package is afaics higher than the one in EPEL, so I
suggest we leave it like that and and move the existing package to EPEL proper
so users of RHEL&EPEL proper can use it as well. 

I'd further suggest we try to coordinate updates to the package in the future
(with the ENVR in EPEL proper lower then the one in CentOS normally) should
further updates be needed. Alec, z00dax, is that fine for you?
Comment 9 Habig, Alec 2007-12-03 14:01:15 EST
Great, thanks!  Am happy to coordinate future changes changes.  Only one in the
works now would be a big change to use yum-updatesd --oneshot (Bug 325531) which
is a long-term infrastructure change and will proceed slowly and cautiously anyway.
Comment 10 Thorsten Leemhuis 2007-12-05 03:42:03 EST
added a "UPDATE-CAREFULLY" file to yum-cron/EL-5 as reminder. Closing this bug.
Comment 11 Thorsten Leemhuis 2007-12-05 03:43:43 EST
(In reply to comment #10)
> added a "UPDATE-CAREFULLY" file to yum-cron/EL-5 as reminder. Closing this bug.

Ohh, sorry, commit failed; I don't have proper permissions. Alec, could you
please add a file similar to
http://cvs.fedora.redhat.com/viewcvs/rpms/yum/EL-4/UPDATE-CAREFULLY?view=markup
as reminder to CVS? tia!

Note You need to log in before you can comment on or make changes to this bug.