Bug 303301 - Why is jpl disabled?
Why is jpl disabled?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pl (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 11:20 EDT by Mary Ellen Foster
Modified: 2008-11-26 03:03 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 03:03:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec-file patch (3.08 KB, patch)
2008-01-30 11:26 EST, Mary Ellen Foster
no flags Details | Diff

  None (edit)
Description Mary Ellen Foster 2007-09-24 11:20:56 EDT
Description of problem:
SWI Prolog ships with a Java interface. However, it's explicitly disabled (via a
"--without-jpl" argument to configure) in the Fedora package. Why is this? I
just tried rebuilding without that configure argument, and there were no errors
on the build (although I haven't heavily tested the resulting RPM). This will
probably BuildRequire java-devel, but I don't think that's an issue.

(Also, version 5.6.41 is now out ...)

Version-Release number of selected component (if applicable):
pl-5.6.35-1.fc7
Comment 1 Gérard Milmeister 2007-09-24 14:28:39 EDT
I managed to build the java library using the fedora java stack with a few
tweaks. However I have not tested whether it works as it should.
Comment 2 Mary Ellen Foster 2007-09-25 03:36:57 EDT
If you're going to include jpl, it would be good to also include the package
documentation.
Comment 3 Mary Ellen Foster 2008-01-25 09:19:24 EST
*ping*?

Also, SWI is at 5.4.49 now
Comment 4 Mary Ellen Foster 2008-01-30 11:26:26 EST
Created attachment 293430 [details]
Spec-file patch

I've done a bit of experimentation. There was actually a bug in JPL that caused
it to segfault almost immediately when running anything in Fedora, but that
seems to be on the way to being fixed, and there don't appear to be any other
problems.

I've updated the spec file to 5.6.49 and enabled jpl as a sub-package, and
uploaded the spec file and resulting srpm here:
http://mef.fedorapeople.org/packages/pl/

Note that, by default, jpl seems only to be happy on Sun-like JVMs, so I've
explicitly required java-icedtea rather than just java; the sub-package is
therefore only available on Fedora >=8 and not on PPC. It does builds on my
(i386) Fedora 8 machine, although I keep having weird issues building in Koji.
I'll send it here anyway.

The spec-file diff is attached.

I'm happy to co-maintain pl if you want a co-maintainer (vested interest since
I'm currently using it on a project :) )
Comment 5 Gérard Milmeister 2008-01-30 14:21:22 EST
I would be glad I you help maintain the package, so you can
proceed and update the package.

About your spec file:
- The license should probably be LGPLv2
- The CFLAGS need "-fno-strict-aliasing"

Anyway you should base your changes on the current spec file.
Comment 6 Mary Ellen Foster 2008-02-04 11:27:47 EST
Oh, I didn't realise that there was a new version in Rawhide. I've redone my
patch against the latest spec. The new srpm and spec are at
http://mef.fedorapeople.org/packages/pl/, along with a diff against the rawhide
spec.

Why does it need "-fno-strict-aliasing"? I added it, but I must admit I don't
really understand what it does.
Comment 7 Gérard Milmeister 2008-02-04 11:50:56 EST
On rawhide at least the code would not compile without -fno-strict-aliasing.
Strict aliasing is an assumption made by the compiler use for optimization.
However, the code needs to satisfy certain conditions, for example that
variables must not be aliased via different types.
Comment 8 Mary Ellen Foster 2008-02-22 09:20:19 EST
I just tried using mock to build pl on rawhide without -fno-strict-aliasing, and
it compiled with no errors. I can't run the resulting package as I don't have a
rawhide machine, but it doesn't seem to be needed.

I've been heavily using the packages built from the srpm I linked to earlier on
Fedora 8, though, and I've been having no problems. Any chance of getting the
jpl-enabled stuff packaged? Like I said, I'm willing to co-maintain because I
currently use this package daily for my work.
Comment 9 Gérard Milmeister 2008-02-22 10:28:26 EST
(In reply to comment #8)
> Fedora 8, though, and I've been having no problems. Any chance of getting the
> jpl-enabled stuff packaged? Like I said, I'm willing to co-maintain because I
> currently use this package daily for my work.
I would appreciate your co-maintainership. BTW, pl fails to build with the new
GCC 4.3 in rawhide, so this and jpl would be two issues to investigate.
Comment 10 Mary Ellen Foster 2008-02-22 10:39:14 EST
Actually, I just successfully built my test package in mock against rawhide as
part of testing the -fno-strict-aliasing; it looks like whatever was causing it
not to build with GCC4.3 has possibly already been removed upstream ...
Comment 11 Gérard Milmeister 2008-02-22 10:44:37 EST
I suggest that you request co-maintainership and check in your changes.
Comment 12 Mary Ellen Foster 2008-02-22 11:32:49 EST
Thanks for enabling the ACLs. I've checked in my changes -- should I try a "make
build"?

(Perhaps this is abuse of the bugzilla "comment" feature and I should just take
it to email at this point ... :) )
Comment 13 Fedora Update System 2008-06-27 06:43:50 EDT
pl-5.6.57-1.fc8 has been submitted as an update for Fedora 8
Comment 14 Fedora Update System 2008-06-28 18:14:51 EDT
pl-5.6.57-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5786
Comment 15 Bug Zapper 2008-11-26 02:50:42 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Mary Ellen Foster 2008-11-26 03:03:12 EST
Not sure why this bug didn't auto-close ...

Note You need to log in before you can comment on or make changes to this bug.