Bug 303431 - Won't print multiple copies
Won't print multiple copies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 11:58 EDT by Tim Waugh
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.3.0-6.1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 09:43:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-09-24 11:58:39 EDT
Description of problem:
When trying to print multiple copies of a document, only one copy appears.

Version-Release number of selected component (if applicable):
2.3.0-5.1.fc8

How reproducible:
100%

Steps to Reproduce:
  1.Create a three page document in OpenOffice.org Writer
2.Export to a PDF, call it test.pdf
3.Open PDF in Evince
4.File->Print...
5.Select a duplex-capable printer
6.Focus on the Page Setup tab
7.For Two-Sided select Long Edge (Standard)
8.Focus on the General tab
9.Select 2 copies
10.Make the 'Collate' check-box selected
11.Click Print

Actual results:
Two sheets of paper end up in the output tray, 1-2 3-blank

Expected results:
Four sheets of paper end up in the output tray, 1-2 3-blank 1-2 3-blank

Additional info:
This worked correctly in Fedora 7 with 2.3.0-5.1.fc8.
Comment 1 Tim Waugh 2007-09-24 12:02:16 EDT
Corrected steps to reproduce:
1.Create a three page document in OpenOffice.org Writer
2.File->Print...
3.Select a duplex-capable printer
4.Focus on the Page Setup tab
5.For Two-Sided select Long Edge (Standard)
6.Focus on the General tab
7.Select 2 copies
8.Make the 'Collate' check-box selected
9.Click Print
Comment 2 Caolan McNamara 2007-10-06 11:15:10 EDT
Hmm, I do see a problem with the last print job settings getting "stuck" on
subsequent operations. How about now in rawhide with openoffice.org-2.3.0-6.1 ?
Comment 3 Tim Waugh 2007-10-09 08:26:18 EDT
2.3.0-6.1.fc8 seems to behave correctly.  Thanks!
Comment 4 Caolan McNamara 2007-10-09 09:43:50 EDT
awesome, I've pushed all the work of copies and collation off to cups so I'm
particularly delighted that it works now that I've remembered to clear the
previous print job settings.

Note You need to log in before you can comment on or make changes to this bug.