Bug 30347 - make --short-circuit work with -bb
Summary: make --short-circuit work with -bb
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-build
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-02 17:45 UTC by Sammy
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-03-02 17:46:01 UTC


Attachments (Terms of Use)

Description Sammy 2001-03-02 17:45:58 UTC
I have been trying to rebuild XFree86 RPMS using the CVS updates and
because of some typos in x files and the spec I had to do it number
of times (it takes many hours to compile)...I could slowlt solve my
problems throught -bc and -bi with --short-circuit so that I did not
recompile from scratch each time....but at the end I saw that there
was no option to so the final binary files without restarting all over
again although the -bi stage was all done.....

Comment 1 Bill Nottingham 2001-03-02 19:33:36 UTC
No. The idea behind RPM is *reproducible* builds; hence, anything
that builds actual packages has to go through a full run of the spec file.


Note You need to log in before you can comment on or make changes to this bug.