Bug 3035 - tcsh does not set environment variables according to /etc/sysconfig/i18n
tcsh does not set environment variables according to /etc/sysconfig/i18n
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-25 08:55 EDT by Kolar, Petr
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-24 22:56:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kolar, Petr 1999-05-25 08:55:11 EDT
If some user has tcsh as her login shell, the environment
variables LC_ALL, LANG, LINGUAS etc. (which are set by the
script /etc/profile.d/lang.sh for bash) are not set. This
bug is in Red Hat since introducing /etc/sysconfig/i18n.

------- Email Received From  Alex deVries <adevries@redhat.com> 05/25/99 11:31 -------
Comment 1 Kolar, Petr 1999-05-25 11:42:59 EDT
To correct the bug use /etc/profile.d/lang.csh with this contents:

-------------------------------------------------------------------
if ( -r /etc/sysconfig/i18n ) then
        eval `sed -e 's/ *#.*//' -e 's/^\([^=][^=]*\)=\(.*\)/setenv \1
\2;/' /etc/sysconfig/i18n`
endif
-------------------------------------------------------------------

If no comments are allowed in /etc/sysconfig/i18n, then "-e 's/
*#.*//'"
can be omitted.
Comment 2 Jay Turner 1999-06-28 11:39:59 EDT
This issue has been forwarded to a developer for further action.
Comment 3 Bill Nottingham 1999-09-24 22:56:59 EDT
This is fixed in the latest initscripts - it has a lang.csh.

Note You need to log in before you can comment on or make changes to this bug.