Bug 3036 - pppd cannot connect under 6.0 where it can under 5.2
pppd cannot connect under 6.0 where it can under 5.2
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-05-25 09:27 EDT by martin
Modified: 2015-01-07 18:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-06-28 11:41:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description martin 1999-05-25 09:27:11 EDT
Modem comms work under 6.0 via /dev/ttyS0 in the same way
they work under 5.2 for /dev/cua0. I get full connection and
login to my isp with no problems. (Incidentally, your 6.0
doc still refers to /dev/cuaN !!!!!!!!!)

However, I cannot get the 6.0 pppd to complete the
connection, where 5.2 always manages (well, truthfully, 6.0
managed it once out of about 20 tries, but dropped the
connection 3 minutes later).

I use the exact same command line for both:

pppd /dev/modem 115200 -detach netmask \ crtscts defaultroute debug

(/dev/modem IS correctly set up as a sym link to /dev/ttyS0
under 6.0 and /dev/cua0 under 5.2 - and, just to test, I
tried the connection directly through /dev/ttyS0 but that
didn't work)

Setserial output for /dev/modem on the systems is:

/dev/modem uart 16550A port 0x03f8 irq 4 spd_vhi
    skip_test (6.0)

/dev/modem, UART: 16550A, Port: 0x03f8, IRQ: 4,
    Flags: spd_vhi (5.2)

I have debug traces for both systems, the 6.0 trace showing
many lines similar to this:

 May 25 14:21:27 nitram pppd[2026]: rcvd [LCP ProtRej id=0x8
72 63 76 64 20 5b 4c 43 50 20 50 72 6f 74 52 65 6a 20 69 64
3d 30 78 33 20 30 30 20 34 33 20 36 66 20 36 65 20 36 65 20
36 35 20 36 33 20 37 34 20 33 61 20 32 30 20 37 30 20 37 30
20 37 30 20 33 30 20 32 30 20 33 63 20 32 64 20 32

In fact, the 6.0 log does vary a little - I have sent the
most common, but there is sometimes a complete failure to
get any response to config requests. And, as I said, it did
ONCE work with a log very similar to that of 5.2 - but only
once - it dropped after three minutes after which I
attempted the same thing again and received a similar log to
Comment 1 testspamaccount 1999-05-28 02:40:59 EDT
Had the same problem with LCP on a new 6.0 system for a dialup. I'm
sure your modem is fine i to used cua0 in 5.2 but now use ttyS0 in
6.0. I traced it to the /etc/ppp/options file cleared out everything
but a line for "lock" . Then used netcfg to do it over instead of
manually from a command line. worked fine ended LCP error messages. i
just use ifup ppp0 now.
Comment 2 shane 1999-05-29 03:00:59 EDT
I am having the same problems.  I have tried replacing pppd with a
version I know works.. but with no luck.  I changed
/etc/ppp/ppp-secrets chap-secrets and options to match a machine that
currently works.. but this also did not work.  I have tried
recompiling the kernel to 2.2.9 with ppp loaded as both a module and
built in.. None of this has resulted in a working pppd connection.
Comment 3 shane 1999-05-30 23:51:59 EDT
I have the same problem, nither gppp or kppp will connect sucessfully

However running linuxconf and setting up your ppp account from there
then issuing the /etc/sysconfig/network-scripts/ifup ppp0 will connect

   *note* when running linuxconf's ppp configuration everything goes
very slowly and the xterm I started it from reports warnnings.
Comment 4 martin 1999-05-31 10:50:59 EDT
Well I (the person who logged it) now have it working.

And, I am almost ashamed to say, it was as simple as NOT attempting to
use the old version of kde I have hanging around for my 5.2 backup
system, but installing the kde that comes with RH 6 - It was a last
resort attempt with the thought "no WAY is this the reason" - and I
haven't had a problem with it since!!!!!!!


Note You need to log in before you can comment on or make changes to this bug.