This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 30370 - genhdlist cannot hanle relative paths
genhdlist cannot hanle relative paths
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-02 15:30 EST by Gerald Teschl
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-03 20:45:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-03-02 15:30:04 EST
Using a relative path as argument to genhdlist fails

[root@soliton redhat-7.1]# ./genhdlist .
error opening directory ./RedHat/RPMS: No such file or directory

Using the full path works:
[root@soliton redhat-7.1]# ./genhdlist `pwd`
Comment 1 Erik Troan 2001-03-04 19:11:18 EST
This is an RFE, not a bug. That said, I'd welcome a patch.
Comment 2 Gerald Teschl 2001-03-07 04:27:17 EST
It worked in the previours version, so it will break existings scripts for no
good reason.
I consider this a bug;-). I would send you a fix if I had some time, which isn't
going to
happen in the next few month I'm afraid. And, btw, YOU get paid for this!

Note You need to log in before you can comment on or make changes to this bug.