Bug 304051 - [PATCH] compiz fails to redraw gnome-terminal
[PATCH] compiz fails to redraw gnome-terminal
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Target
  Show dependency treegraph
Reported: 2007-09-24 16:59 EDT by Warren Togami
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-10 14:16:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-09-24 16:59:03 EDT
compiz fails to redraw gnome-terminal under certain circumstances, making it
very annoying to use gnome-terminal in compiz.

Example #1
1) gnome-terminal
2) maximize window
3) Screen is blank until you force it to redraw with ALT-TAB twice.

Example #2
1) gnome-terminal
2) Maximize window, ALT-TAB twice
3) New tab twice
4) exit
5) exit
6) Failed to redraw back to a single tab.
Comment 1 Thomas J. Baker 2007-09-26 10:30:52 EDT
I'm seeing this also with both intel and nvidia hardware. With intel hardware,
toggle_maximize full, horizontal, or vertical causes the redraw problem (I only
use toggles, haven't tried with just regular maximizes). With nvidia, only max
and horizontal cause the problem, though vertically unmaximizing causes a blank
window until a character is typed. Current compiz-0.5.2-12.6b86f3.fc8.x86_64
Comment 2 Warren Togami 2007-10-02 11:44:05 EDT
Confirmed, if I make gnome-terminal the size of the screen without using
maximize, then I workaround this problem.
Comment 3 Thomas J. Baker 2007-10-02 15:41:54 EDT
Seems like there is a patch in git for this problem in this thread:

Comment 4 Warren Togami 2007-10-02 17:31:38 EDT
I tried this patch and it solves my problem!
Comment 5 Warren Togami 2007-10-10 14:16:06 EDT

Note You need to log in before you can comment on or make changes to this bug.