Bug 30406 - Pump fails to work with tr0; Sometimes kernel panics while trying
Pump fails to work with tr0; Sometimes kernel panics while trying
Status: CLOSED DUPLICATE of bug 28139
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-02 19:10 EST by Scott Russell
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-04 23:59:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Russell 2001-03-02 19:10:34 EST
Using an ibmtr_cs supported IBM Toekn Ring PC card in a ThinkPad T20 loaded
with Wolverine may panic the system if trying to configure via pump.
(dhcpcd apparently has no token ring support and / or also fails.)

Both pump and dhcpcd seem to work fine with a wvlan silver card on the same
network and ThinkPad. (The LAN is the IBM internal network in Raleigh.)

"*.debug" output from syslogd shows:

Mar  2 18:53:35 lizzard syslogd 1.4-0: restart.
Mar  2 18:53:35 lizzard syslog: syslogd startup succeeded
Mar  2 18:53:35 lizzard kernel: klogd 1.4-0, log source = /proc/kmsg started.
Mar  2 18:53:35 lizzard kernel: Inspecting /boot/System.map-2.4.1-0.1.9
Mar  2 18:53:35 lizzard syslog: klogd startup succeeded
Mar  2 18:53:35 lizzard kernel: Loaded 14165 symbols from
/boot/System.map-2.4.1-0.1.9.
Mar  2 18:53:35 lizzard kernel: Symbols match kernel version 2.4.1.
Mar  2 18:53:35 lizzard kernel: Loaded 274 symbols from 11 modules.
Mar  2 18:53:34 lizzard syslog: syslogd shutdown succeeded 

*** I insert the adapter here

Mar  2 18:53:46 lizzard cardmgr[680]: socket 0: IBM Token Ring Adapter
Mar  2 18:53:46 lizzard cardmgr[680]: executing: 'modprobe ibmtr_cs
mmiobase=0xd0000 srambase=0xd4000'
Mar  2 18:53:46 lizzard kernel: ibmtr.c: v1.3.57   8/ 7/94 Peter De
Schrijver and Mark Swanson
Mar  2 18:53:46 lizzard kernel:          v2.1.125 10/20/98 Paul Norton
<pnorton@ieee.org>
Mar  2 18:53:46 lizzard kernel:          v2.2.0   12/30/98 Joel Sloan
<jjs@c-me.com>
Mar  2 18:53:46 lizzard kernel:          v2.2.1   02/08/00 Mike Sullivan
<sullivam@us.ibm.com>
Mar  2 18:53:46 lizzard kernel: tr0: ISA P&P 16/4 Adapter/A (short) | 16/4
ISA-16 Adapter found
Mar  2 18:53:46 lizzard kernel: tr0: using irq 0, PIOaddr a20, 16K shared RAM.
Mar  2 18:53:46 lizzard kernel: tr0: Hardware address : 00:20:35:C0:7B:9F
Mar  2 18:53:46 lizzard kernel: tr0: Shared RAM paging enabled. Page size:
16K Shared Ram size 63K
Mar  2 18:53:46 lizzard kernel: tr0: Maximum MTU 16Mbps: 16344, 4Mbps: 6104
Mar  2 18:53:46 lizzard kernel: tr0: port 0xa20, irq 3, mmio 0xd0000, sram
0xd4000,
Mar  2 18:53:46 lizzard kernel:   hwaddr=002035C07B9F
Mar  2 18:53:46 lizzard /etc/hotplug/net.agent: register event not handled

*** The following is because I don't have /etc/sysconfig/network-scripts 
*** setup as of yet.

Mar  2 18:53:46 lizzard cardmgr[680]: executing: './network start tr0'
Mar  2 18:53:46 lizzard cardmgr[680]: + usage: ifup <device name>
Mar  2 18:53:46 lizzard cardmgr[680]: start cmd exited with status 1
Mar  2 18:53:48 lizzard kernel: tr0: Initial interrupt : 16 Mbps, shared
RAM base 000d4000.
Mar  2 18:53:48 lizzard kernel: tr0: Opend adapter: Xmit bfrs: 2 X 2048,
Rcv bfrs: 16 X 1032
Mar  2 18:53:50 lizzard kernel: tr0: Adapter initialized and opened.

*** Life is good. Now I run "/sbin/pump -i tr0" At this point everything 
*** is a mystery.

Mar  2 18:55:07 lizzard pumpd[2025]: starting at (uptime 0 days, 0:15:45)
Fri Mar  2 18:55:07 2001  
Mar  2 18:55:07 lizzard kernel: tr0: Setting functional address: 00 00 00 00 
Mar  2 18:55:07 lizzard kernel: tr0: Setting functional address: 00 04 00 00 
Mar  2 18:55:07 lizzard kernel: tr0: Setting functional address: 00 04 00 00 
Mar  2 18:55:07 lizzard pumpd[2025]: PUMP: sending discover 
Mar  2 18:55:07 lizzard pumpd[2025]: breq: opcode: 1
Mar  2 18:55:07 lizzard pumpd[2025]: breq: hw: 32
Mar  2 18:55:07 lizzard pumpd[2025]: breq: hwlength: 6
Mar  2 18:55:07 lizzard pumpd[2025]: breq: hopcount: 0
Mar  2 18:55:07 lizzard pumpd[2025]: breq: xid: 0x3fcabcca
Mar  2 18:55:07 lizzard pumpd[2025]: breq: secs: 0
Mar  2 18:55:07 lizzard pumpd[2025]: breq: flags: 0x0000
Mar  2 18:55:07 lizzard pumpd[2025]: breq: ciaddr: 0.0.0.0
Mar  2 18:55:07 lizzard pumpd[2025]: breq: yiaddr: 0.0.0.0
Mar  2 18:55:07 lizzard pumpd[2025]: breq: server_ip: 0.0.0.0
Mar  2 18:55:07 lizzard pumpd[2025]: breq: bootp_gw_ip: 0.0.0.0
Mar  2 18:55:07 lizzard pumpd[2025]: breq: hwaddr: 
Mar  2 18:55:07 lizzard pumpd[2025]: breq: servername: 
Mar  2 18:55:07 lizzard pumpd[2025]: breq: bootfile: 
Mar  2 18:55:07 lizzard pumpd[2025]: breq: vendor: 0x63 0x53 0x82 0x63
Mar  2 18:55:07 lizzard pumpd[2025]: breq: vendor:  53   1 0x01
Mar  2 18:55:07 lizzard pumpd[2025]: breq: vendor: 0xff
Mar  2 18:55:37 lizzard kernel: tr0: Setting functional address: 00 04 00 00 
Mar  2 18:55:37 lizzard kernel: tr0: unknown command in asb 07
Mar  2 18:55:37 lizzard kernel: tr0: ASB error 01 in cmd 07
Mar  2 18:55:37 lizzard kernel: tr0: ASB not free !!!
Mar  2 18:55:38 lizzard kernel: tr0: Adapter closed.
Mar  2 18:55:40 lizzard kernel: tr0: Initial interrupt : 16 Mbps, shared
RAM base 000d4000.
Mar  2 18:55:40 lizzard kernel: tr0: Opend adapter: Xmit bfrs: 2 X 2048,
Rcv bfrs: 16 X 1032
Mar  2 18:55:42 lizzard kernel: tr0: Adapter initialized and opened.
Mar  2 18:55:42 lizzard kernel: tr0: Setting functional address: 00 00 00 00 
Mar  2 18:55:42 lizzard kernel: tr0: Setting functional address: 00 04 00 00 
Mar  2 18:55:42 lizzard kernel: tr0: Setting functional address: 00 04 00 00 
Mar  2 18:55:42 lizzard pumpd[2025]: PUMP: sending discover 
Mar  2 18:55:42 lizzard pumpd[2025]: breq: opcode: 1
Mar  2 18:55:42 lizzard pumpd[2025]: breq: hw: 32
Mar  2 18:55:42 lizzard pumpd[2025]: breq: hwlength: 6
Mar  2 18:55:42 lizzard pumpd[2025]: breq: hopcount: 0
Mar  2 18:55:42 lizzard pumpd[2025]: breq: xid: 0x3fcabcaf
Mar  2 18:55:42 lizzard pumpd[2025]: breq: secs: 0
Mar  2 18:55:42 lizzard pumpd[2025]: breq: flags: 0x0000
Mar  2 18:55:42 lizzard pumpd[2025]: breq: ciaddr: 0.0.0.0
Mar  2 18:55:42 lizzard pumpd[2025]: breq: yiaddr: 0.0.0.0
Mar  2 18:55:42 lizzard pumpd[2025]: breq: server_ip: 0.0.0.0
Mar  2 18:55:42 lizzard pumpd[2025]: breq: bootp_gw_ip: 0.0.0.0
Mar  2 18:55:42 lizzard pumpd[2025]: breq: hwaddr: 
Mar  2 18:55:42 lizzard pumpd[2025]: breq: servername: 
Mar  2 18:55:42 lizzard pumpd[2025]: breq: bootfile: 
Mar  2 18:55:42 lizzard pumpd[2025]: breq: vendor: 0x63 0x53 0x82 0x63
Mar  2 18:55:42 lizzard pumpd[2025]: breq: vendor:  53   1 0x01
Mar  2 18:55:42 lizzard pumpd[2025]: breq: vendor: 0xff
Mar  2 18:56:12 lizzard kernel: tr0: Setting functional address: 00 04 00 00 
Mar  2 18:56:13 lizzard kernel: tr0: Adapter closed.

*** Pump failed with "Operation Failed". Run "/sbin/cardctl eject 0" 
*** and save this log.

Mar  2 18:56:24 lizzard cardmgr[680]: executing: './network check tr0'
Mar  2 18:56:24 lizzard cardmgr[680]: shutting down socket 0
Mar  2 18:56:24 lizzard cardmgr[680]: executing: './network stop tr0'
Mar  2 18:56:24 lizzard cardmgr[680]: + usage: ifdown <device name>
Mar  2 18:56:24 lizzard cardmgr[680]: stop cmd exited with status 1
Mar  2 18:56:24 lizzard cardmgr[680]: executing: 'modprobe -r ibmtr_cs'
Mar  2 18:56:24 lizzard /etc/hotplug/net.agent: unregister event not supported
Comment 1 Erik Troan 2001-03-03 10:12:41 EST
Token ring is broken in 2.4
Comment 2 Scott Russell 2001-03-04 23:59:25 EST
I've had IBM PCI Token Ring adapters working under 7.1 so I'm not sure how it's
broken unless it's specifically the ibmtr_cs module. When I return to Raleigh on
Friday I'll test the ibmtr_cs with a static IP to verify it inserts into the
ring correctly and handles data traffic.

I think this is a DHCP / Token Ring issue. Apparently from my limited reading of
the DHCP spec and other clients (ISC has a dhcp client that behaves alot nicer
with token ring) a DHCP request on token ring is formated slightly different
from a DHCP address on ethernet.

I haven't checked the pump source code yet but I susspect as a first guess that
this is the root of the problem. Of course, without checking the source first I
could also be talking out my...
Comment 3 Michael K. Johnson 2001-03-05 12:53:02 EST
If the kernel is panicing, there is a problem in the kernel.
There may also be a problem in pump, but it's hard to tell
that for people whose machines are panicing...

Please test this with the 2.4.2-0.1.19 kernel that will be
arriving in rawhide shortly.

*** This bug has been marked as a duplicate of 28139 ***

Note You need to log in before you can comment on or make changes to this bug.