Bug 30426 - Delete, End, Home keys not working when booting to init 5
Delete, End, Home keys not working when booting to init 5
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-03 00:39 EST by Dave Ellis
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-03 00:39:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Ellis 2001-03-03 00:39:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en]


On several workstations featuring RH7.0, all applicable RH updates, KDE 2.0.1:
Also on several workstations featuring RH7.0, all applicable RH updates, and updated to XFree86 4.0.2, and KDE 2.1:

This issue possibly relates to bug #24036

When booting into init 5 to X / KDE and opening a konsole, the HOME and 
END keys have no effect (other than producing a "beep"), and the DELETE 
key produces a tilde (~) instead of deleting. 

When booting into console mode with init 3, then using the startx command
to start X / KDE, the END, HOME, and DELETE keys behave as expected.

After exhausting the usual fixes and re-reading the applicable HOW-TOs , and
after searching usenet and attempting various suggested solutions there, I'm
stumped.  

I should note here I am using a 104 generic PC Keyboard (this is specified in XF86Config, etc.), and have the language as Canada English, 
Keyboard Layout US.  Changin these settings appears to have little or no impact on this issue.

Bug report #24036 seems to apply to the DELETE key "~" issue, however 
does not mention or address the HOME and END key issues.  I've attempted 
installing the latest tcsh rpm from the /beta/wolverine directory on one 
workstation in the hope it would address the issue, with no luck.

Reproducible: Always
Steps to Reproduce:
See Description field above for details, but to summarize:

1.  Install RH7.0 using custom install with KDE (no Gnome)
2. Configure to boot to init 5 and kdm as login manager
3. Open a console, type in some garbage, then try to HOME, END, or DELETEing a few chanracters.
Comment 1 Eido Inoue 2001-03-14 05:58:11 EST
you don't need the new tcsh rpm... you need to install the new setup rpm which
has a change for the delete in the csh.login.

I couldn't reproduce your problem with the HOME and END keys... can you give
more info?

Note You need to log in before you can comment on or make changes to this bug.