Bug 30468 - whois coredumps with empty host field
Summary: whois coredumps with empty host field
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: whois   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-03 13:46 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-03 13:46:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-03 13:46:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i686)


Whois dump core when you forget to specify a particular whois server (and
specifieing -h).

Reproducible: Always
Steps to Reproduce:
1. whois -h 
2. whois -h whois.ripe.net
3. whois -p
	

Looks like an error in the command line parsing code (doesn`t use getopt I
suppose)

root@goliath [2116] =>ltrace -f whois -h
__libc_start_main(0x08048b70, 2, 0xbffff9e4, 0x08048840, 0x080496ec
<unfinished ...>
__register_frame_info(0x0804a934, 0x0804aa90, 0xbffff988, 0x08048a9e, 0) =
0x4001b51c
strlen(0, 0, 0, 0, 0 <unfinished ...>
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

Comment 1 Nalin Dahyabhai 2001-06-26 06:52:27 UTC
This will be fixed in Raw Hide (1.0.9).


Note You need to log in before you can comment on or make changes to this bug.