Bug 30469 - Non-ASCII characters not displayed correctly
Non-ASCII characters not displayed correctly
Status: CLOSED DUPLICATE of bug 78482
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-03 10:24 EST by Miloslav Trmac
Modified: 2014-03-16 22:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-29 19:18:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2001-03-03 10:24:51 EST
The new initscipts (5.64.2-1) try to display messages according to /etc/sysconfig/i18n settings. I use LANG="cs_CZ", LC_ALL="cs_CZ", SYSFONT="lat2-sun16", SYSFONTACM="iso02" and I have observed the following problems:

- On boot, four messages are printed before the font is loaded. I understand that it is not reasonable to set the font as the first thing that is done; if you want me to, I'll send you a translation for the few messages in cs_CZ without diacritical marks (this is maybe not possible for other languages)

- On shutdown, the messages are also printed with strange characters;

The errors are the same as using echo to a console with noone logged in.

For this "simulation": a workaround is to "echo -e '\033(K'" to the console

(as done in /etc/profile.d/lang.{,c}sh). (The characters then display

correctly until I press CTRL-D to restart mingetty). Thus the solution

might be to output the '\033(K' (with all the conditions from /etc/profile.d/lang.{,c}sh) to start of /etc/rc.

Anyway, maybe the localization is not worth all the trouble...



Thanks
Comment 1 Miloslav Trmac 2002-09-21 14:34:24 EDT
Still the same, even more visible in UTF-8.
Install in cs_CZ (possibly get complete translation from elvis.redhat.com),
and shutdown the system. The shutdown messages show two bad characters
instead of accented characters, UNTIL portmapper (in my case), which
includes /etc/profile.d/lang.sh.

Why can't /etc/profile.d/lang.sh simply be included in /etc/rc.d/rc ?
Comment 2 Miloslav Trmac 2002-10-05 18:58:11 EDT
The same in 8.0 final.
Comment 3 Need Real Name 2002-10-12 10:51:40 EDT
I have a similar problem to recognize non-ASCII chars in portuguese. I've bin
using RedHat since 6.0 and I do allways map some vfat drives. Now, for the 1st
time, those vfat drives, has well has other things where I've used non-ASCII
characters (for instance Kwrite texts) do show a square replacing 2 chars: the
non-ASCII one and the next. I've installed RH8 using english, as I always do,
and choose pt as a second language. I mainly use KDE. One of the side effects is
that directories with non-ASCII chars are locked and cannot be accessed either
from the konqueror or from the command line.
Comment 4 Need Real Name 2002-10-12 10:55:08 EDT
I have a similar problem to recognize non-ASCII chars in portuguese. I've bin
using RedHat since 6.0 and I do allways map some vfat drives. Now, for the 1st
time, those vfat drives, has well has other things where I've used non-ASCII
characters (for instance Kwrite texts) do show a square replacing 2 chars: the
non-ASCII one and the next. I've installed RH8 using english, as I always do,
and choose pt as a second language. I mainly use KDE. One of the side effects is
that directories with non-ASCII chars are locked and cannot be accessed either
from the konqueror or from the command line.
Comment 5 Miloslav Trmac 2002-10-12 11:12:38 EDT
l3cc: that is a separate problem, you probably need to change iocharset= settings
in /etc/fstab to "utf8" instead of whatever you are currently using.
Comment 6 Miloslav Trmac 2002-10-17 03:44:51 EDT
Assuming bug #74701 gets fixed, the translated messages will be used from
the start of /etc/rc.sysinit, so the console initialization should be done
really early.
Comment 7 Carlos 2002-10-29 19:05:40 EST
I have a similar problem using spanish. It seems that some applications such 
as redhat-config-packages fail claiming about invalid UTF-8 chars.  
Using konqueror as browser I noticed one more problem. When displaying web 
pages some of the non-ascii characters are not displayed while others are. The 
difference beetwen them is the font that is being displayed as in some font 
packages there where characters missing. Opening the same pages with mozilla 
result in perfect behaviour because the font used is different. 
There is the same problem with gvim too,while vim works perfect running in a 
<c>konsole</c>.
Comment 8 Carlos 2002-10-29 19:18:07 EST
It seems not to be a problem with characters missing. 
In the problem explained above with konqueror, when clicking on "view page 
source" the fonts are displayed in Kwrite badly as in the navigator. However, 
if you delete the wrong character in Kwrite you can write the right one with 
no problem. 
Comment 9 Milan Kerslager 2002-11-24 06:24:21 EST

*** This bug has been marked as a duplicate of 78482 ***

Note You need to log in before you can comment on or make changes to this bug.