Bug 30473 - Logitech MouseMan glitches
Summary: Logitech MouseMan glitches
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-03 19:48 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-04 17:30:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-03 19:48:27 UTC
Hi!

When I upgraded to RedHat Linux 7.0 it became hard to drag items around, because Linux thinks I'm doubleclicking (when I'm just pressing down the button).

The mouse works well under - uhm - another operating system.
My /etc/sysconfig/mouse is the same as before.

Is it something with my configuration? The kernel? XFree86?

Regards,

Per Johansson

Comment 1 Mike A. Harris 2001-03-03 20:07:00 UTC
I haven't seen your configuration.  ;o)  I'll bet it is what the problem
is though.  I am using a Logitech Mouseman+ Wheel.  I also have 4 other
Logitech mice and they all work fine.  If it is misconfigured however,
I have seen weird behaviour like you speak of.  Quit X, and run
"mouseconfig".  Choose "Logitech Mouseman" and choose 3 button if it is
3 button, etc..  Also, make sure you select Serial or PS/2 correctly.
Save and exit and startx.  All should be well.  Either way, please come back
here and let me know.

Hope this helps!
TTYL

Comment 2 Need Real Name 2001-03-03 21:10:48 UTC
Hi!

My /etc/sysconfig/mouse is
MOUSETYPE="ps/2"
XMOUSETYPE="PS/2"
FULLNAME="Logitech MouseMan/FirstMouse (PS/2)"
XEMU3=no

The pointer section in /etc/X11/XF86Config is
Section "Pointer"
    Protocol    "PS/2"
    Device      "/dev/mouse"
EndSection

My /dev/mouse/ points to /dev/psaux that has Major,Minor=10,1

Running mouseconfig, selecting Logitech MouseMan/FirstMouse (PS/2), gives the same configuration.

What else could it be? I'm running GNOME/Enlightenment. I'm not running gpm.

Regards,

Per Johansson

Comment 3 Mike A. Harris 2001-03-04 08:36:02 UTC
Edit your XF86config-4 and try different mouse drivers out.  I recommend
trying "MouseManPlusPS/2" first, and if that doesn't work, try,"ImPS/2",
then "MouseMan", then possibly "Logitech".  Finally if all else fails,
try the "Auto" setting.

Also, you might want to check out the manual page for this.
man -a mouse
(hit q once and you'll get the XFree86 mouse manpage)

Please let me know which one works for you so I can change the default driver
to one that works properly.

TIA

Comment 4 Need Real Name 2001-03-04 17:30:19 UTC
Problem solved!

Hi,

for som reason I don't know, I didn't have a "XF86Config-4" (only the old "XF86Config". I recreated it with Xconfigurator. That file was unfortunately broken (missing font paths and errornous modelines) but it was there. After some tweaking, X runs like a charm. Even Xev gives normal output.

Oh, and btw, the best mouse protocol seems to be "PS/2" for my mouse.

Thank You very much. I had never looked into XF86Config-4 if You hadn't mentioned that file.

The very best regards,

Per Johansson

Comment 5 Mike A. Harris 2001-03-06 16:43:41 UTC
Great, glad we got it working for ya!


Note You need to log in before you can comment on or make changes to this bug.