This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 304841 - Please use opengl-games-utils DRI checking wrapper
Please use opengl-games-utils DRI checking wrapper
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gl-117 (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-25 08:00 EDT by Hans de Goede
Modified: 2008-07-30 16:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.3.2-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 16:10:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2007-09-25 08:00:36 EDT
In preperation for the Games Live DVD, I've created a small bash script which
resides in opengl-games-utils, which is meant to be used as a wrapper around
OpenGL games. If DRI is available this wrapper does nothing, if it isn't it will
show an error dialog, explaining about Free Software and 3D drivers and then exit.

The idea here is that an error dialog is better then trying to click the quit
menu option while the mouse is jumping from the right edge of the screen to the
left edge (mouse navigation is anything but easy at 3 fps).

This is esp. important for the Games Live DVD, as there people will not have
those other <beep> drivers available.

Adding the wrapper is _really_ easy:

1) Add: "Requires: opengl-games-utils"
2) Add to %install:
"ln -s opengl-game-wrapper.sh $RPM_BUILD_ROOT%{_bindir}/%{name}-wrapper"
3) Add "%{_bindir}/%{name}-wrapper" to %files
4) Change the .desktop file Exec entry from "%{name}" to "%{name}-wrapper"

This all assumes your main binary name == %{name}, otherwise adapt as necessary.

If you already have a wrapper script for one reason or the other, you can
incorperate the checkDriOk function directly into your wrapper, no need todo a
wrapper wrapper, see vegastrike's vegastrike-wrapper.sh CVS file as example.
Comment 1 Steven Pritchard 2007-10-18 18:05:36 EDT
I'd be completely OK with someone taking care of this for me, since I have no
idea when I'll get around to it right now.  (And at this rate, if it isn't done
very soon, it won't make F8 final.)
Comment 2 Bug Zapper 2008-04-04 09:54:30 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 3 Hans de Goede 2008-04-04 10:23:32 EDT
This bug is still present in current rawhide changing version back to rawhide.
Also the .desktop file contains the forbidden Categories Application and
X-Fedora, and lacks further refinement of the Games Category, I believe a proper
Categories field for this apps .desktop would be:

Categories=Games;Simulation;

All in all it looks like this package needs some love, Steve? If you're too busy
to get around to this let me know and I'll fix it. (Assuming cvs extras has
rights on this).

Comment 4 Steven Pritchard 2008-07-03 17:14:03 EDT
(In reply to comment #3) 
> All in all it looks like this package needs some love, Steve? If you're too
busy
> to get around to this let me know and I'll fix it. (Assuming cvs extras has
> rights on this).

Sorry, I seem to have missed this comment when you made it.

For the record, you always have my permission to update/modify any of my
packages as needed.  I wouldn't mind an email (or a bugzilla ticket comment)
when it happens though, just so I know.

In any case, this should all be fixed in 1.3.2-7 (in rawhide, building now).  If
everything looks good, I can push updates to F-8 and F-9.
Comment 5 Fedora Update System 2008-07-03 19:59:58 EDT
gl-117-1.3.2-7.fc8 has been submitted as an update for Fedora 8
Comment 6 Hans de Goede 2008-07-04 00:50:01 EDT
Looks good now, what about also issuing this as an update for F-9 ?
Comment 7 Fedora Update System 2008-07-06 02:16:52 EDT
gl-117-1.3.2-7.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gl-117'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-6151
Comment 8 Fedora Update System 2008-07-30 16:09:58 EDT
gl-117-1.3.2-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.