Bug 30486 - qt-2.2.4 -- missing BuildRequire
qt-2.2.4 -- missing BuildRequire
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-03 16:06 EST by R P Herrold
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 16:19:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2001-03-03 16:06:45 EST
In rebuilding qt-2.2.4 frpm SRPM, it lacks a buildrequirement:

 
g++ -D_REENTRANT -DQT_THREAD_SUPPORT -c -I/usr/X11R6/include
-I/usr/src/redhat/BUILD/qt-2.2.4/include -I/usr/X11R6/include -pipe -O2
-march=i386 -mcpu=i686 -fno-exceptions  -DQT_BUILTIN_GIF_READER=1 -DQT_XFT
-fno-exceptions  -I/usr/X11R6/include  -o kernel/qapplication_x11.o
kernel/qapplication_x11.cpp

In file included from kernel/qapplication_x11.cpp:119:
kernel/qt_x11.h:77:25: X11/Xft/Xft.h: No such file or directory
Comment 1 Bernhard Rosenkraenzer 2001-03-06 07:32:15 EST
It's quite obvious that qt would require XFree86-devel...
I'll add the BuildPrereq when updating qt the next time, but this minor glitch 
doesn't warrant a new build just to fix this.
Comment 2 R P Herrold 2001-03-06 10:52:03 EST
Concur -- but this issue will catch folks in the local LUGs,
It is one line in the spec file -- How about doing the edit, and
a RAWHIDE close ?
Comment 3 Bernhard Rosenkraenzer 2001-03-06 16:22:08 EST
We close bugs as rawhide only if a new package has been built at least in the 
internal tree.
I can savely close it as rawhide now because I've just updated the package to 
2.3.0 though. ;)
Comment 4 R P Herrold 2001-03-06 19:23:54 EST
Thank you for the clarification -- I was unaware of that distinction

-- Russ Herrold

Note You need to log in before you can comment on or make changes to this bug.