Bug 30510 - RFE: Better keyboard setup in XFree86
RFE: Better keyboard setup in XFree86
Status: CLOSED DEFERRED
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-keyboard (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-03 22:27 EST by Elliot Lee
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 23:24:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliot Lee 2001-03-03 22:27:13 EST
The user should be able to expect to make use of the hardware they have.
One of the devices that today's average user commonly has is a keyboard
with more than 101 keys.

The current XF86Config config generated doesn't seem to include an XkbModel
line to set the model as appropriate, so that the extra keys can be used.

What is requested here is an addition to Xconfigurator to allow the user to
select their keyboard model (or autodetect it, if this is possible).

Other changes to make the keys work properly for apps may be needed, but
they all depend on having the X server aware of the keyboard in the first
place...
Comment 1 Elliot Lee 2001-03-07 19:56:41 EST
My neglect to see the pc104 keyboard selection in kbdconfig was part of the
reason this bug was filed; while it is technically possible to have the extra
keys work on a microsoft keyboard, closely linked issues remain:

. kbdconfig is not clear enough for dummies like me
. kbdconfig doesn't allow selecting keyboards with extra keys beyond the 104
(e.g. XkbModel "microsoftpro", meaning my keyboard with all the funky extra
buttons across the top). This problem is probably similar to the monitor database.
. When pc104 and kin are selected, fairly big issues with X apps and Alt vs.
Meta show up. Trond was looking into this issue a bit; perhaps he can provide
some insights.
Comment 2 Elliot Lee 2001-09-10 20:09:46 EDT
Maybe more griping will make something happen here :)

It also seems that layouts for many foreign languages are missing - e.g. Arabic
- which are available from third parties on the 'net. These should be integrated.
Comment 3 Brent Fox 2002-06-04 23:24:06 EDT
I'm changing the component to the new keyboard tool.  Let's try to get keyboards
right once and for all.
Comment 4 Brent Fox 2002-08-01 08:12:32 EDT
I'm going to defer this one.  I'd like to do this, but we're still trying to get
regular keyboards working at the moment.  ;)  Let's revisit this post-Milan.
Comment 5 Elliot Lee 2002-08-02 11:53:14 EDT
Random thoughts that have floated through my head since I last saw this bug:
1. We need to support the concepts of keyboard-hardware (set on a per-system basis) and 
keyboard-layout (set by each user, either explicitly, or implicitly by choosing a language at 
login), instead of just a single 'keyboard-type' setting like it is now.
2. The various layouts need to be normalized so that they don't produce different keysyms 
for the same key unless it truly makes sense. E.g. My Alt key shouldn't stop being Meta 
just because I switched from pc101 to pc104.
3. Building a keyboard hardware database, being able to import Microsoft .KBD files, etc. 
seems important.

Hope this helps once it's time to come back to this issue.

Note You need to log in before you can comment on or make changes to this bug.