This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 305141 - random muting madness
random muting madness
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-09-25 10:35 EDT by Matthias Clasen
Modified: 2008-06-02 15:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 12:06:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2007-09-25 10:35:03 EDT
When I use the mixer applet while another volume control (gnome-volume-control
or the pulseaudio volume control) is running, muting happens randomly while I
drag the slider.
Comment 1 Bastien Nocera 2007-09-25 11:17:47 EDT
Problem is that there's no get_mute, so the only way to get the status reliably
is to use the new notification mechanism to get updates.

This is a pretty large change to add to gnome-media right now.

There's also problems with the tracks' left and right channels randomly
unlocking themselves from each other, which are probably due to some get_volume
failing within the alsa mixer plugin.

Which version of the mixer applet are you using? It shouldn't mute the track
when volume is reaching 0 anymore.
Comment 2 Matthias Clasen 2007-09-25 12:19:50 EDT
This is with gnome-media-2.20.0-2.fc8


And, urgh, now that I try again, I see random muting even without any other
volume control app running...
Comment 3 Matthias Clasen 2007-09-25 12:32:14 EDT
gnome-applets-2.20.0-5.fc8
Comment 4 Bastien Nocera 2007-09-25 13:06:54 EDT
So that's the mixer applet running on its own causing problems?

The mute overlay is used for volume == 0, and when muted (properly), so this
means that gstreamer/alsa is sending spurious mute updated messages, or that the
volume getting gets 0.

Could you please ltrace the mixer applet and check the results for failed 
snd_mixer_selem_get_playback_volume()?

I haven't been able to reproduce the problem. If the problem comes from spurious
mute messages, I'll cook up a patch to gnome-applets for debugging.
Comment 5 Matthias Clasen 2007-10-03 12:06:33 EDT
I cannot really reproduce the problem anymore here. 
So lets assume that things work better now.
Comment 6 Marc-Andre Lureau 2008-06-02 15:58:59 EDT
Hi there, 

please try also with gnome-media 2.23.3 (should be out in a few hours ;), it
removes the weird code that was muting the device when all sliders where 0, and
was not changing this back according to device events.

Note You need to log in before you can comment on or make changes to this bug.