Bug 305421 - redownloads codecs
redownloads codecs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: codeina (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-25 12:09 EDT by Jeremy Katz
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.10.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-30 19:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-09-25 12:09:26 EDT
After downloading a plugin and having it fail (eg, due to the SElinux issue),
codeina still redownloads the plugin the next time you try to do it even though
it still has a copy of the tarball in ~/.local
Comment 1 Bastien Nocera 2007-09-26 07:35:05 EDT
We don't have any checksums in the available-plugins.xml file, so we don't know
whether the download was successful or not.
Comment 2 Jeremy Katz 2007-09-26 10:25:07 EDT
Tarballs instead of rpms (so no real updating), no signatures, no checksums... 
should this be scaring me as much as it is?
Comment 3 Bastien Nocera 2007-09-27 09:19:18 EDT
There's updating support (although it requires an updated available-plugins.xml,
which is sub-par). I've added sha1sum support in my local repo though. Feel free
to file another bug about specific security concerns, and not pile on to this bug.

Note You need to log in before you can comment on or make changes to this bug.