Bug 30554 - Bad dependency in ipt_MASQUERADE module (2.4.0 preview)
Bad dependency in ipt_MASQUERADE module (2.4.0 preview)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-04 10:19 EST by Avi Alkalay
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-04 10:19:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Alkalay 2001-03-04 10:19:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.4.0-0.26 i686)


Using kernel-2.4.0-0.26 (from preview packages in RH7.0 CD), the
ipt_MASQUERADE module incorrectly needs ipchains module to be loaded. As a
result, when trying "modprobe ipt_MASQUERADE", the system tryies to insmod
ipchains, but fails because iptables is already loaded.

I found the dependency in modules.dep file.

Reproducible: Always
Steps to Reproduce:
1. lsmod will not show neither iptalbes or ipchains modules loaded.
2. If trying to 'modprobe ipt_MASQUERADE' I got unresolved symbol
"ip_nat_setup_info".
3. If I 'modprobe iptable_nat' first, this symbol will be available.
4. Then I 'modprobe ipt_MASQUERADE' and got "failed to insmod ipchains",
because iptables is already loaded.
5. A workaround it to simply "insmod ipt_MASQUERADE" after "modprobe
iptable_nat".
Comment 1 Michael K. Johnson 2001-03-05 13:10:13 EST
This should be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.