This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 30558 - Can't print to Epson Stylus Color 480
Can't print to Epson Stylus Color 480
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-04 11:23 EST by Avi Alkalay
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-19 16:27:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
testpage.prn (588.73 KB, application/octet-stream)
2002-03-15 09:33 EST, Tim Waugh
no flags Details
printconf-gui screenshot (12.60 KB, image/png)
2002-04-18 11:00 EDT, Avi Alkalay
no flags Details

  None (edit)
Description Avi Alkalay 2001-03-04 11:23:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.4.0-0.26 i686)


This is what I have:
LPRng-3.6.24-2
rhs-printfilters-1.81-1
printtool-3.54-1
ghostscript-5.50-8
kudzu-0.72-3
kernel-2.4.0-0.26 (from preview directory on RH7.0 CD)

I can't make my Epson Stylus Color 480 print.
It doesn't even make any noise when trying to print.

I tryed to follow some instructions in the following URLs, without success:
http://www.eunuchs.org/epson/
http://lcewww.et.tudelft.nl/~haver/linux/epson.html

Output of 'cat /proc/sys/dev/parport/parport0/autoprobe':
CLASS:PRINTER;
MODEL:Stylus COLOR 480;
MANUFACTURER:EPSON;
DESCRIPTION:EPSON Stylus COLOR 480;
COMMAND SET:ESCPL2,BDC,D4;

Why kudzu doesn't detect my printer?

Reproducible: Always
Steps to Reproduce:
1. Create a queue with printtool, selecting Epson Stylus Color (UP)
2. Restart LPRng (lpd)
3. lpr anyfile.txt; lpr anyfile.ps
	

Actual Results:  I can see the jobs for some seconds in the queue (using
lpq), then they desapear.
It seems that for ghostcript, the filters and LPRng everything was OK. lpd
sent the data to /dev/lp0, but the printer stays quiet, and nothing is
printed.

I can use the printer under MS-Windows.
Comment 1 Crutcher Dunnavant 2001-03-29 15:32:58 EST
please try the following:

	 echo -ne "a b c d\r\nb\r\nc\r\nd\r\n\014" > /dev/lp0

this 'should' produce:

	a b c d
	b
	c
	d

if it does not, there is a kernel issue. Please attach a copy of the output of

	dmesg

A parallel port problem was recently solved so it is possible that we've got
this one, but lets see.
Comment 2 Avi Alkalay 2001-03-31 00:13:09 EST
Output of `dmesg`:

----------------------------------------
Linux version 2.4.0-0.26 (prospector@test148.test.redhat.com) (gcc version 2.96
20000731 (experimental)) #1 Fri Aug 25 09:36:25 EDT 2000
BIOS-provided physical RAM map:
 e820: 000000000009fc00 @ 0000000000000000 (usable)
 e820: 0000000000000400 @ 000000000009fc00 (reserved)
 e820: 0000000000010000 @ 00000000000f0000 (reserved)
 e820: 0000000007ef0000 @ 0000000000100000 (usable)
 e820: 0000000000008000 @ 0000000007ff0000 (ACPI data)
 e820: 0000000000008000 @ 0000000007ff8000 (ACPI NVS)
 e820: 0000000000010000 @ 00000000ffff0000 (reserved)
On node 0 totalpages: 32752
zone(0): 4096 pages.
zone(1): 28656 pages.
zone(2): 0 pages.
Kernel command line: auto BOOT_IMAGE=Linux ro root=306
BOOT_FILE=/boot/vmlinuz-2.4.0-0.26 hdb=noprobe hdd=noprobe scsihosts=0
ide_setup: hdb=noprobe
ide_setup: hdd=noprobe
Initializing CPU#0
Detected 704954893 Hz processor.
Console: colour VGA+ 132x43
Calibrating delay loop... 1405.75 BogoMIPS
HIGHMEM: notramhighpages: 0, ramhighpages: 0.
Memory: 126516k/131008k available (1470k kernel code, 4104k reserved, 111k data,
220k init, 0k highmem)
Dentry-cache hash table entries: 16384 (order: 5, 131072 bytes)
Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 8192 (order: 4, 65536 bytes)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: L1 I Cache: 64K  L1 D Cache: 64K (64 bytes/line)
CPU: L2 Cache: 512K
CPU: AMD Athlon(tm) Processor stepping 01
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.36 (20000221) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xfd9e1, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router VIA [1106/0586] at 00:04.0
isapnp: Scanning for Pnp cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 8192 bind 8192)
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.13)
ACPI: "AMI" found at 0x000faf50
ACPI: found platform errata 0x00000030
acpi: APM is already active.
Starting kswapd v1.7
pty: 256 Unix98 ptys configured
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller on PCI bus 00 dev 21
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
AMD IronGate
 Chipset Core ATA-66
Split FIFO Configuration:  8 Primary buffers, threshold = 1/2
                           8 Second. buffers, threshold = 1/2
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
ide0: VIA Bus-Master (U)DMA Timing Config Success
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
ide1: VIA Bus-Master (U)DMA Timing Config Success
hda: WDC AC310200R, ATA DISK drive
hdc: IDE/ATAPI CD-ROM 36X, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 20044080 sectors (10263 MB) w/512KiB Cache, CHS=1247/255/63
hdc: ATAPI 16X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.11
Partition check:
 hda: hda1 hda3 < hda5 hda6 hda7 hda8 hda9 hda10 > hda4
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
md.c: sizeof(mdp_super_t) = 4096
LVM version 0.8final  by Heinz Mauelshagen  (15/02/2000)
lvm -- Driver successfully initialized
scsi : 0 hosts.
scsi : detected total.
Serial driver version 5.02 (2000-08-09) with MANY_PORTS MULTIPORT SHARE_IRQ
SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10c
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 220k freed
Adding Swap: 31208k swap-space (priority -1)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.237 $ time 09:43:02 Aug 25 2000
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0xcc00, IRQ 9
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
usb.c: USB new device connect, assigned device number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xc800, IRQ 9
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
usb.c: USB new device connect, assigned device number 1
hub.c: USB hub found
hub.c: 2 ports detected
Via 686a audio driver 1.1.8
via82cxxx: timeout while reading AC97 codec
ac97_codec: AC97 audio codec, id: 0x4144:0x5340 (Analog Devices AD1881)
via82cxxx: board #1 at 0xD800, IRQ 10
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 94M
agpgart: Detected AMD Irongate chipset
agpgart: AGP aperture is 64M @ 0xe0000000
8139too Fast Ethernet driver 0.9.7 loaded
eth0: RealTek RTL8139 Fast Ethernet board found at 0xebfeff00, IRQ 9
eth0:   Chip is 'RTL-8139B'
eth0:   MAC address 00:50:bf:06:77:e1.
VFS: Disk change detected on device ide1(22,0)
Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
SMSC Super-IO detection, now testing Ports 2F0, 370 ...
0x378: FIFO is 16 bytes
0x378: writeIntrThreshold is 8
0x378: readIntrThreshold is 8
0x378: PWord is 8 bits
0x378: Interrupts are ISA-Pulses
0x378: possible IRQ conflict!
0x378: ECP port cfgA=0x10 cfgB=0x00
0x378: ECP settings irq=<none or set by other means> dma=<none or set by other
means>
parport0: PC-style at 0x378 (0x778), irq 7, dma 255
[PCSPP,TRISTATE,COMPAT,ECP,DMA]
parport0: dma 255 in use, resorting to PIO operation
parport0: cpp_daisy: aa5500ff(98)
parport0: assign_addrs: aa5500ff(98)
parport0: Printer, EPSON Stylus COLOR 480
parport_pc: Via 686A parallel port: io=0x378, irq=7, dma=255
lp0: using parport0 (interrupt-driven).
lp0: console ready
----------------------------------------
Comment 3 Tim Waugh 2001-12-19 07:35:04 EST
It seems it's been a while since any action has been taken on this bug report, 
unfortunately.  Are you still experiencing this problem?

Does the 2.2.x kernel give the same problem? (The latest kernel update for Red 
Hat Linux 7.0 is 2.2.19-7.0.12.)
Comment 4 Tim Waugh 2001-12-19 07:35:51 EST
Also, what exactly was the outcome of the 'echo' command?  Did anything print?
Comment 5 Avi Alkalay 2001-12-19 11:31:53 EST
Now I'm using RedHat 7.2b (I have to upgrade to 7.2+updates) and still can't 
print.

The output for the echo was nothing. Didn't worked. That is whay I sent 
a 'dmesg' output.
Comment 6 Tim Waugh 2001-12-19 11:35:30 EST
Which kernel are you using now?  2.4.9-13?

Can you show me the dmesg output for the kernel that you are using now please? 
I'd like to check to see if a bug that is visible in the 2.4.0-xxx dmesg 
output is indeed now gone, in which case I can eliminate that as being the 
cause.
Comment 7 Tim Waugh 2002-03-06 08:27:14 EST
*ping*
Comment 8 Avi Alkalay 2002-03-11 10:54:34 EST
No I'm using 7.2 with all updates (kernel-2.4.9-13), and still can't print.
When configuring a printer with printtool, which driver should I select? There 
are 2 or 3 to choose. Also, there is no Epson Stylus 480. Which compatible 
printer should I select? Epson 400?
Comment 9 Tim Waugh 2002-03-12 11:55:44 EST
Are you looking for 'Epson Stylus _Color_ 480' (my emphasis)?
Comment 10 Avi Alkalay 2002-03-12 13:31:36 EST
It is Epson Stylus Color 480. Sorry.
We should also change the product version to Red Hat Linux 7.2.
Comment 11 Tim Waugh 2002-03-15 09:32:29 EST
Are you using US Letter paper size?  Please try printing the attached file like
this (as root):

cat testpage.prn > /dev/lp0

Let me know the result.
Comment 12 Tim Waugh 2002-03-15 09:33:42 EST
Created attachment 48624 [details]
testpage.prn
Comment 13 Avi Alkalay 2002-03-16 00:33:18 EST
OK, my printer was detached....
I attached it, "service lpd stop", and "cat testpage.prn > /dev/lp0".

It worked!! I got the Color US Letter RedHat Princonf test page.

Which driver should I select? And if I want to print in black and white also?
Comment 14 Avi Alkalay 2002-03-23 16:20:47 EST
*ping*
Comment 15 Tim Waugh 2002-04-02 03:42:53 EST
Epson Stylus Color 480.  For B&W printing some applications give you this option
anyhow (gimp, for example).  Otherwise, you can set up another queue with
different driver options.
Comment 16 Avi Alkalay 2002-04-02 19:50:59 EST
I didn't understand how to solve this problem. This printer is not listed 
printtool's list.

Please specify *exact* drivers and filters I have to select for color and for 
B&W.
Comment 17 Tim Waugh 2002-04-04 07:49:10 EST
You should see 'Epson'->'Stylus Color 480'.  B&W or Color can be selected under
'Driver Options' (look at 'Output Type').

The original problem in this report (can't printer at all) is solved--if you
think that there is an issue with B&W/Color, please open a separate report for it.

Thanks.
Comment 18 Avi Alkalay 2002-04-18 11:00:52 EDT
Created attachment 54344 [details]
printconf-gui screenshot
Comment 19 Avi Alkalay 2002-04-18 11:12:33 EDT
As you can see in my printconf-gui screenshot, I don't have this printer in the 
printers list.
Even if it was there, which driver should I select? 

I'm using printconf-gui-0.3.61-3, Omni-0.5.0-4, foomatic-1.1-0.20011218.3, 
ghostscript-6.51-16

Thank you,
Avi
Comment 20 Tim Waugh 2002-04-19 08:26:15 EDT
Do you have foomatic-1.1-0.20011218.3 (the latest issue for that release) 
installed?
Comment 21 Avi Alkalay 2002-04-19 16:27:26 EDT
As I wrote in my last bug report (2002-04-18 11:12:33), I'm using foomatic-1.1-
0.20011218.3.
Comment 22 Tim Waugh 2002-05-02 10:21:07 EDT
Well, try 460->stp.  I don't know; it looks like full support for the 480 came 
after 7.2+updates. 
 
(For example, Skipjack [the current beta] will have '480' listed explicitly.)

Note You need to log in before you can comment on or make changes to this bug.