Bug 30577 - konqueror and bugzilla don't get on
Summary: konqueror and bugzilla don't get on
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdelibs (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-04 23:05 UTC by Tim Waugh
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 17:11:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broken cookies (624 bytes, text/plain)
2001-03-20 15:59 UTC, Tim Waugh
no flags Details
working cookies (700 bytes, text/plain)
2001-03-20 16:00 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2001-03-04 23:05:03 UTC
When querying bugzilla with non-standard columns, you get different 
columns that you ask for.

Comment 1 Bernhard Rosenkraenzer 2001-03-05 16:21:30 UTC
submitted to KDE bug tracking system


Comment 2 Bernhard Rosenkraenzer 2001-03-05 16:52:02 UTC
This is bug 21593 in the KDE bug tracking system.

Comment 3 Bernhard Rosenkraenzer 2001-03-06 12:23:19 UTC
This is fixed in 2.1-7


Comment 4 Tim Waugh 2001-03-20 11:13:09 UTC
This seems to be broken again in 2.1-10.

Comment 5 Tim Waugh 2001-03-20 11:23:24 UTC
Hmm, maybe it was a bad cookie.  I logged out, removed 
.kde/share/apps/kcookie/cookie and logged in again, and this bug no longer 
happens (also the 'logout doesn't work' bug has gone away too).

I'll keep my eye out for this and reopen if I see it again.


Comment 6 Tim Waugh 2001-03-20 15:57:52 UTC
Okay, this is definitely still happening, albeit less frequently than before 
(i.e. sometimes vs. always).

It is working fine right now, but a few minutes ago it broke again.  I will 
attach the cookies file that I deleted (after it went wrong), and the cookies 
file that now exists after I've logged in again and set up the columns.

It looks just like the cookies file is getting read incorrectly and then 
written out again.


Comment 7 Tim Waugh 2001-03-20 15:59:50 UTC
Created attachment 13144 [details]
broken cookies

Comment 8 Tim Waugh 2001-03-20 16:00:49 UTC
Created attachment 13145 [details]
working cookies

Comment 9 Tim Waugh 2001-03-20 16:32:45 UTC
Okay, how to reproduce it:

1. Start with no cookie file.  rm ~/.kde/share/apps/kcookiejar/cookies
2. Log on using KDE.
3. Start konqueror.
4. Log in to bugzilla.
5. Adjust columns (do a query and click on 'change columns').
6. Observe that it works properly.  Close konqueror.
7. Log out, and log in again (to KDE).
8. Start konqueror, do a query.
9. Observe that the columns are now wrong.  Look in cookies file and see that 
the cookies look fine.
10. Log out, and log in again (to KDE).
11. Look at cookies file and see that some bits are truncated to the first 
word.



Comment 10 Tim Waugh 2001-03-20 17:05:03 UTC
KCookieServer::putCookie just does:

         case CF_DOMAIN :
            *out << cookie->domain();
            break;
         case CF_NAME :
            *out << cookie->name();
            break;
         case CF_PATH :
            *out << cookie->path();
            break;
         case CF_HOST :
            *out << cookie->host();
            break;
         case CF_VALUE :
            *out << cookie->value();
            break;

etc.  It's never escaping spaces.  This is broken.


Comment 11 Tim Waugh 2001-03-20 17:11:20 UTC
parseField also looks wrong: it allows whitespace by dequoting, but doesn't 
allow both quotes and whitespace in the value (so value 'quote " mark' can 
never be stored).



Comment 12 Bernhard Rosenkraenzer 2001-03-21 17:31:57 UTC
Fixed for real in 2.1.1-2.




Note You need to log in before you can comment on or make changes to this bug.