Bug 30595 - /etc/sysconfig/network is not sourced at ifdown
Summary: /etc/sysconfig/network is not sourced at ifdown
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-05 00:44 UTC by Pekka Savola
Modified: 2014-03-17 02:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 00:44:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2001-03-05 00:44:37 UTC
/sbin/ifdown does not source /etc/sysconfig/network.

Traditionally this isn't really necessary for devices for which you just ifconfig it down,
but IPv6 can use a little more sophisticated approach.  However, this will not be done
for 'eth' devices because:

if [ "${NETWORKING_IPV6}" = "yes" ]; then
    /etc/sysconfig/network-scripts/ifdown-ipv6 $DEVICE
fi

and NETWORKING_IPV6 is not known in this context.


I suggest that /etc/sysconfig/network be sourced either 
 1) beginning of the file (this might _perhaps_ break some really
controversial OTHERSCRIPT's if they use GATEWAY 
 2) after OTHERSCRIPT is exec'ed

Comment 1 Bill Nottingham 2001-03-05 06:32:37 UTC
Will be fixed in 5.70-1 (after OTHERSCRIPT, FWIW.)


Note You need to log in before you can comment on or make changes to this bug.