Bug 306311 - konqueror chokes on flash plugin
konqueror chokes on flash plugin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-25 21:24 EDT by Alexei Podtelezhnikov
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 06:12:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 463773 None None None Never
KDE Software Compilation 132138 None None None Never

  None (edit)
Description Alexei Podtelezhnikov 2007-09-25 21:24:06 EDT
It looks like Fedora 8 development (KDE) will come with konqueror which is 
incompatible with Adobe Flash 9.0.48. Konqueror becomes unresponsive and has 
to be killed. Firefox works fine with that third party plugin.
Comment 1 Ngo Than 2007-09-26 04:43:51 EDT
I don't see the problem with Adobe Flash 9.0.48. It works fine for me.
Comment 2 Alexei Podtelezhnikov 2007-09-26 11:50:41 EDT
Ok, then explain which package I am missing in my installation from Fedora Kde 
Live?

(process:5766): GLib-GObject-CRITICAL **: gtype.c:2242: initialization 
assertion failed, use IA__g_type_init() prior to this function

(process:5766): GLib-CRITICAL **: g_once_init_leave: assertion 
`initialization_value != 0' failed

(process:5766): Gtk-CRITICAL **: gtk_clipboard_get_for_display: assertion 
`GDK_IS_DISPLAY (display)' failed
Adobe FlashPlayer: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying to 
call gtk_init(0,0);
Killed
Comment 3 Rex Dieter 2007-09-26 12:16:59 EDT
$rpm -q flash-plugin
flash-plugin-9.0.31.0-release.i386

works, newer (beta) versions currently do not.
Comment 4 Rex Dieter 2007-09-26 12:47:35 EDT
fwiw, see also http://bugs.kde.org/132138
Comment 5 Alexei Podtelezhnikov 2007-09-26 13:09:40 EDT
Thanks for confirmation. This should be in the Fedora KDE Caveats.
Still, how come 9.0.48 works for Than? 

Comment 6 Alexei Podtelezhnikov 2007-09-26 13:12:35 EDT
Thanks for confirmation. This should be in the Fedora KDE Caveats.
Still, how come 9.0.48 works for Than? 

Comment 7 Alexei Podtelezhnikov 2007-09-26 13:19:55 EDT
Also, scanning folders enabled flash-plugin. How do I disable it now? Not so
easy.... 
Comment 8 Alexei Podtelezhnikov 2007-09-26 20:08:53 EDT
More fresh references on the issue:
http://lists.kde.org/?t=119077340800003&r=1&w=2

I will reopen the bug, because brushing this issue under the rug doesn't help.
A lot of people will be pretty disappointed in Fedora-KDE release 8.

By the way, Fedora 6 with KDE 3.5.7 and some gtk packages works just fine with 
Adobe Flash plugin, so please - just let me know which package is missing from 
KDE-Live CD so that can fix it. I know that I should be able to.

Comment 9 Rex Dieter 2007-09-26 21:48:54 EDT
My apologies if you perceived closing this UPSTREAM as a brush off.  Per,
https://bugzilla.redhat.com/page.cgi?id=bug_status.html#resolution
It means:

"... bugs closed with this resolution are filed in the upstream bug tracker or
reported to the upstream mailing list. This typically includes almost all
feature requests and enhancements, and most bugs that we don't consider release
showstoppers. (moving a bug upstream typically increases the chance that someone
will have time to look at it, and often the upstream developer or bug owner even
works at Red Hat - moving things upstream simply allows us to keep everything in
one place, and work better with open source community developers outside of Red
Hat. We only keep bugs open on redhat.com to track our immediate short-term TODO
items, or issues with our patches/packaging, or because the upstream package in
question has poor bug tracking. The main focus of development for most packages
is the upstream community, even when Red Hat is a big contributor to the
community.)..."

We will certainly continue to track the issue at
http://bugs.kde.org/show_bug.cgi?id=132138

Comment 10 Rex Dieter 2007-09-26 21:52:24 EDT
Possible related issue:
http://bugzilla.gnome.org/show_bug.cgi?id=463773
Comment 11 Rex Dieter 2007-09-26 21:56:34 EDT
Matthias, looks like we may be seeing a manifestation of
http://bugzilla.gnome.org/show_bug.cgi?id=463773
I assume our gtk2 doesn't include the workaround patch mentioned there?
Comment 12 Matthias Clasen 2007-09-26 22:12:55 EDT
Your assumption is wrong.
Comment 13 Ngo Than 2007-09-27 06:12:17 EDT
the workaround for the flash plugin was included in gtk2-2.11.6-9 or newer.
please upgrade to current gtk2 version in rawhide. Thanks
Comment 14 Alexei Podtelezhnikov 2007-09-27 07:46:35 EDT
Thanks, it's good now.
Out of curiosity, why Firefox never needed any workaround in gtk2?
Comment 15 Matthias Clasen 2007-09-28 19:08:29 EDT
The problem only occurs when gtk has not already been initialized when the flash
plugin is loaded. 

Note You need to log in before you can comment on or make changes to this bug.