Bug 306341 - [radeon xpress 200] X loops hard with DRI
Summary: [radeon xpress 200] X loops hard with DRI
Status: CLOSED DUPLICATE of bug 415111
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-26 01:35 UTC by Jens Petersen
Modified: 2018-04-11 13:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 13:14:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci_-vv.output (10.75 KB, text/plain)
2007-09-26 01:58 UTC, Jens Petersen
no flags Details
regs.txt (14.71 KB, text/plain)
2007-09-26 02:08 UTC, Jens Petersen
no flags Details
xorg.conf (577 bytes, text/plain)
2007-09-30 00:20 UTC, Jens Petersen
no flags Details
Xorg.0.log (54.92 KB, text/plain)
2007-09-30 01:02 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2007-09-26 01:35:24 UTC
Description of problem:
X goes into a hard loop with Radeon Xpress 200 when using DRI.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.7.193-1.fc8
xorg-x11-drv-ati-6.7.194-1.fc8

How reproducible:
every time

Steps to Reproduce:
1. boot rawhide or livecd
  
Actual results:
1. after rhgb, X goes into a hard loop when it tries to start X for gdm.

Expected results:
1. run normally

Additional info:
Turning off DRI and everything seems to be ok.

Comment 1 Jens Petersen 2007-09-26 01:56:40 UTC
# lspci -n
00:00.0 0600: 1002:5a33 (rev 01)
00:01.0 0604: 1002:5a3f
00:11.0 0101: 1002:437a (rev 80)
00:12.0 0101: 1002:4379 (rev 80)
00:13.0 0c03: 1002:4374 (rev 80)
00:13.1 0c03: 1002:4375 (rev 80)
00:13.2 0c03: 1002:4373 (rev 80)
00:14.0 0c05: 1002:4372 (rev 81)
00:14.1 0101: 1002:4376 (rev 80)
00:14.2 0403: 1002:437b (rev 01)
00:14.3 0601: 1002:4377 (rev 80)
00:14.4 0604: 1002:4371 (rev 80)
01:05.0 0300: 1002:5a61
02:03.0 0780: 14f1:2f20
02:05.0 0200: 10ec:8139 (rev 10)
02:06.0 0c00: 1106:3044 (rev c0)


Comment 2 Jens Petersen 2007-09-26 01:58:45 UTC
Created attachment 206321 [details]
lspci_-vv.output

This is the output of "lspci -vv".

Comment 3 Jens Petersen 2007-09-26 02:08:05 UTC
Created attachment 206331 [details]
regs.txt

Output of "radeontool regmatch \*".

Comment 4 Matěj Cepl 2007-09-26 15:15:39 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 5 Jens Petersen 2007-09-30 00:18:06 UTC
Dave, I tested xorg-x11-drv-ati-6.7.194-2.fc8 with

* Fri Sep 28 2007 Dave Airlie <airlied@redhat.com> 6.7.194-2
- radeon-6.7.194-disable-rc410-dri.patch - Disable DRI on
  RC410 by default as it seems to need some more work.

and yes that worksaround the problem.

Comment 6 Jens Petersen 2007-09-30 00:20:44 UTC
Created attachment 211501 [details]
xorg.conf

Here is the xorg.conf file (it is just the standard one) -
this is from a live image.

Comment 7 Jens Petersen 2007-09-30 01:02:10 UTC
Created attachment 211511 [details]
Xorg.0.log

and here is the log file too when X "crashes".

Comment 8 Matěj Cepl 2008-01-25 13:14:01 UTC

*** This bug has been marked as a duplicate of 415111 ***


Note You need to log in before you can comment on or make changes to this bug.