Bug 30642 - aic7xxx and de4x5 modules seem to conflict
aic7xxx and de4x5 modules seem to conflict
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 08:47 EST by Chris Carlson
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 11:10:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Carlson 2001-03-05 08:47:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.14-5.0 i586)


I have the standard release of RH 6.2 installed on a Gateway K6 system with
96M of RAM, and two ethernet cards.  Normally, this system auto-loads
modules de4x5 and eepro100 to support the two ethernet cards.  The two
cards are a LinksysPCI LAN card and a non-descript Intel card supplied by
Gateway (chip numbers available if needed).

When I install my SCSI card (Adaptec AVA-2906), during startup the system
detects the new hardware and Kudzu asks if I want to configure the SCSI
card.  No matter what I choose (configure, ignore or skip), the system
hangs when it initializes the ethernet cards.  Note, the SCSI card's
existence seems to be the problem.  The system initializes eth0 (the
eepro100) and hangs during initialization of eth1 (the de4x5 driver).


Reproducible: Always
Steps to Reproduce:
1.Install Adaptec AVA-2906 card.
2.Boot up.
3.Kudzu detects new hardware.
4.Choose any option to configure or not.
5.At the point when the ethernet cards are initialized (in
/etc/rc.d/init.d/network), the system will hang when initializing the de4x5
driver.


Actual Results:  System hangs.  <CTRL><ALT><DEL> has no effect.


Expected Results:  System continues to boot after initializing ethernet
cards.
Comment 1 Bill Nottingham 2001-03-05 11:10:25 EST
Does it behave better if you use the tulip driver instead of de4x5?
Comment 2 Chris Carlson 2001-03-05 23:24:45 EST
Absolutely!  It's strange that Kudzu selected de4x5 rather than the tulip driver
(must search drivers in alphabetical order).

Thanks a lot!

P.S. I searched the FAQ and bugzilla for de4x5 related issues and didn't find
anything of interest.

Note You need to log in before you can comment on or make changes to this bug.