Bug 30643 - ONBOOT ignored for eth0 when eth0 is a pcmcia NIC
ONBOOT ignored for eth0 when eth0 is a pcmcia NIC
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 08:51 EST by Scott Russell
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 23:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Russell 2001-03-05 08:51:24 EST
The ONBOOT="no" option appears to be ignored for eth0 NICs which are 
pcmcia adapters. The init scripts seem to ignore the eth0 interface 
however the Red Hat pcmcia script /etc/pcmcia/network goes ahead and 
brings it up anyway if the card is found in the socket at boot. 

ONBOOT does seem to work for ppp0 where /dev/ttyS1 is a pcmcia modem in 
slot 0. When ONBOOT="no" in ifcfg-ppp0 the device does not attempt to 
start up even if it is in the slot at boot. 

Laptop is an IBM Thinkpad T20 running Red Hat Wolverine (7.1 RC1) and the 
stock initscripts / kernel / pcmcia packages.
Comment 1 Bill Nottingham 2001-03-05 10:55:27 EST
This is normal behavior for PCMCIA/cardbus NICs.
Comment 2 Scott Russell 2001-03-05 22:47:16 EST
How exactly is this normal behavior? If an interface is set to be ONBOOT="n"
it's expected that during boot that it won't come up. 

The reason this happens in the first place is because of the custom Red Hat /
network script integration going on in /etc/sysconfig/network-scripts and
/etc/pcmcia.

Before closing this as "not a bug" I think it needs more consideration. The real
soluton is better Red Hat / pcmcia integration. A hack job would be to document
that this is a problem and in the netcfg control panel make this option
unavailable if the interfaces is a pcmcia nick. (Possibly check /var/pcmcia/stab
for info?)

While we're at it, why is it that networking starts before pcmcia services in
the first place? This seems to be a Red Hat only thing, but I could be wrong.

So can we please make /etc/pcmcia/network parse the
/etc/sysconfig/networking-scripts/ifcfg-if0 scripts instead of blindly bringing
up the interface?
Comment 3 Bill Nottingham 2001-03-05 23:06:02 EST
It's normal behavior in that that's the way it's always been.
It's also the behavior you'll get from hotplug when that is used for
cardbus or pcmcia interfaces. In any case, this is not an initscripts
problem.
Comment 4 Michael K. Johnson 2001-03-12 12:47:49 EST
I do not expect this to be changed for this release.

Note You need to log in before you can comment on or make changes to this bug.