Bug 306601 - setuptool under x86_64 is missing nameserver information under Network Setup
setuptool under x86_64 is missing nameserver information under Network Setup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 05:38 EDT by Ralph Angenendt
Modified: 2009-01-20 16:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* DNS addresses could not be manually entered in either the GUI or text interfaces. This meant that no DNS could be specified if a static IP was used or if DHCP failed to retrieve DNS information. This updated version of system-config-network allows DNS addresses to be set in both graphical and text mode.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:54:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Angenendt 2007-09-26 05:38:45 EDT
Description of problem:

Under 5 i386 when using "setup" to setup networking, you are asked if you want
to set up networking and get a form where you can enter IP address, network
mask, default gateway and the primary nameserver's ip address.

Under x86_64 you are asked to chose the network device you want to setup and are
asked for the name of the device, the device itself, the static ip, the netmask
and the default gateway's IP address, but you cannot enter name server
information anywhere. 

So if you rely on this tool, you end up with a broken resolv.conf, as no
nameserver information is put into there.

Setting up DHCP works, if you have a dhcp server running.

Version-Release number of selected component (if applicable):

setuptool-1.19.2-1.el5.centos.x86_64 (branding has been removed from that)

How reproducible:

Run setup on an x86_64 RHEL 5 machine

Additional info:

This bug has been entered into the centos bug tracker, see
http://bugs.centos.org/view.php?id=1910 for more information.

Cheers,

Ralph
Comment 1 Nalin Dahyabhai 2007-09-26 09:25:50 EDT
On both architectures, it looks like setuptool is launching
/usr/sbin/system-config-network-tui, moving to that package.
Comment 2 Fabio Olive Leite 2007-11-12 15:28:49 EST
Reassigning to component owner.
Comment 3 Phil Knirsch 2008-04-28 07:56:38 EDT
Proposing for RHEL-5.3 but waiting for developer review for ACK.

Read ya, Phil
Comment 4 RHEL Product and Program Management 2008-06-02 16:31:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Phil Knirsch 2008-06-13 08:45:44 EDT
This bug needs a review from the component owner before granting Devel ACK.

Thanks,

Read ya, Phil
Comment 6 Phil Knirsch 2008-06-19 11:24:14 EDT
Granting Devel ACK after review of the package maintainer

Thanks,

Read ya, Phil
Comment 11 Ruediger Landmann 2009-01-08 01:45:49 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* DNS addresses could not be manually entered in either the GUI or text interfaces. This meant that no DNS could be specified if a static IP was used or if DHCP failed to retrieve DNS information. This updated version of system-config-network allows DNS addresses to be set in both graphical and text mode.
Comment 12 errata-xmlrpc 2009-01-20 16:54:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0193.html

Note You need to log in before you can comment on or make changes to this bug.