Bug 306631 - autofs reload and condrestart fail if map is originally empty
autofs reload and condrestart fail if map is originally empty
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs5 (Show other bugs)
4.6
All Linux
medium Severity low
: rc
: ---
Assigned To: Ian Kent
: Regression
Depends On: 254226
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 05:54 EDT by Ian Kent
Modified: 2008-07-24 15:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0659
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:08:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Kent 2007-09-26 05:54:34 EDT
+++ This bug was initially created as a clone of Bug #254226 +++

+++ This bug was initially created as a clone of Bug #199441 +++

Description of problem:

autofs doesn't start up when running "service autofs start" if the maps are
empty.  I understand that 
this is probably by design, but it leads to another bug.

If you have autofs on in chkconfig, then change the map and call "service autofs
reload", it should load 
the new map.  However, because the service doesn't start when the map is empty,
the reload (as well as 
the condrestart) both fail to make autofs turn on.

When autofs is turned on in chkconfig, scripts and programs should have the
expectation that autofs is 
running when the machine is on, and should be able to call condrestart and
reload without worrying 
about it failing.

Version-Release number of selected component (if applicable):

autofs-4.1.3-169

How reproducible:

Always

Steps to Reproduce:
1. Autofs is off; user is root
2. Supply an empty /etc/auto.master file (the default file installed by the rpm
is fine)
3. Run "/sbin/service autofs start"
4. Replace the auto.master file with one that has at least one mount
5. Call "/sbin/service autofs reload" or "/sbin/service autofs condrestart"
  
Actual results:

autofs fails to reload / restart.

Expected results:

autofs SHOULD reload / restart

Additional info:

-- Additional comment from ayacoub@yahoo.com on 2006-07-19 12:41 EST --
Created an attachment (id=132695)
Patch for /etc/init.d/autofs

This one-line patch fixes this bug.  This init.d file is written, however, for
both Debian and RedHat.  My patch only addresses the issue on RedHat.  I don't
even know if the bug exists on Debian.

-- Additional comment from pm-rhel@redhat.com on 2007-08-28 01:27 EST --
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 1 RHEL Product and Program Management 2007-09-26 06:04:29 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Barry Donahue 2008-02-18 16:00:30 EST
Manual test is described in the bug.
Comment 3 Jeffrey Moyer 2008-02-18 16:10:16 EST
(In reply to comment #2)
> Manual test is described in the bug.

Actually, test /CoreOS/autofs/bugzillas, subtest bz199441 covers this case.  No
manual testing is required.
Comment 4 Ian Kent 2008-02-18 21:58:43 EST
(In reply to comment #3)
> (In reply to comment #2)
> > Manual test is described in the bug.
> 
> Actually, test /CoreOS/autofs/bugzillas, subtest bz199441 covers this case.  No
> manual testing is required.

Yes, I have that listed as the test for this bug.
Sorry I didn't update the bug.
Comment 5 Ian Kent 2008-03-25 00:21:07 EDT
The RHTS sub-test bz199441 in the autofs workflow can be used to
verify this bug.

Please use autofs5-5.0.1-0.rc2.87.
Comment 7 Barry Donahue 2008-06-12 09:33:09 EDT
Verified RHTS job #23575.
Comment 9 errata-xmlrpc 2008-07-24 15:08:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0659.html

Note You need to log in before you can comment on or make changes to this bug.