Bug 30671 - Compilation of program fails
Compilation of program fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 13:38 EST by Andrew Potter
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 20:16:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Potter 2001-03-05 13:38:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en] (X11; I; Linux 2.2.12 i686)


The error message is:
command.c :36
parse error before '_extension_'

Line 36 in command.c is
extern char * strstr(const char *, const char *);

The program compiles OK using unix in Sun machines.  

Reproducible: Always
Steps to Reproduce:
1.tar -xvf vfudgit_4.2.tar
2.cd Fudgit_2.41  (this directory is created by tar)
3. make linux

 (I can ftp vfudgit_4.2.tar to you if your tell me where.)
	

Actual Results:  Compilation failed with the error message given in
Description

Expected Results:  Program should have compiled OK.  It works OK for unix
on Sun machines.
Comment 1 Andrew Potter 2001-03-05 20:16:03 EST
I forgot to mention that the program will compile OK with Slackware Linux, v 3.
Comment 2 Jakub Jelinek 2001-03-06 07:28:09 EST
This looks like a bug in vfudgit: it should not supply prototypes for functions
provided by libc. In this case it breaks because strstr is defined as a macro
in glibc if optimizing (and it is allowed to do so). Either remove the offending
prototypes, or compile with -D__NO_STRING_INLINES which will result in strstr
and a couple of other string functions not being defined as macros.

Note You need to log in before you can comment on or make changes to this bug.