Bug 30676 - [aic7xxx] Kernel panics when booting 'new' aix7xxx module on SMP system
[aic7xxx] Kernel panics when booting 'new' aix7xxx module on SMP system
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 14:22 EST by Dana H. Myers
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 04:23:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dana H. Myers 2001-03-05 14:22:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)


Installed Fisher on dual-processor system (MMX-200 in venerable old Intergraph TD-40); upon reboot, system panics reliably when loading 
SCSI module - aic7xxxx (TD-40 contains an AIC-7850 on motherboard for SCSI support).

Booting the UP kernel succeeds; I'm then able to build an SMP kernel with the 'old' aic7xxx driver.
Booting SMP with the old aic7xxx works fine, as far as I can tell.

Reproducible: Always
Steps to Reproduce:
1. Install Fisher on TD-40 with dual CPU
2. Boot Linux in SMP mode
3. Watch it explode.  It blowed up.
	

Actual Results:  Systems reliably panics when loading aic7xxx module during boot

Expected Results:  System should display SCSI probe information and successfully boot up and run.
Comment 1 Dana H. Myers 2001-03-05 15:48:47 EST
After a normal install, I can not reproduce this problem with Wolverine; I suspect Wolverine is using the 'old' aic7xxx driver.
Comment 2 Arjan van de Ven 2001-03-06 04:22:47 EST
Yes Wolverine uses the old module.
Comment 3 Doug Ledford 2001-03-07 14:16:16 EST
I'm closing this bug since it can't be reproduced with the old aic7xxx module
and I suspect it won't happen with the latest new aic7xxx module (version 6.1.4
or later) either.
Comment 4 Dana H. Myers 2001-03-07 15:19:05 EST
I might not be too familiar with the bugzilla process, but in my kernel development days, we closed bugs as 'resolved' when the reported problem was 
verified as actually fixed, not when we suspected it would be fixed.

In any case, you might want to update the release notes for Fisher (which is still advertised as the 'latest beta' on the RedHat homepage) to include a 
mention that it will certainly blow up after installation on an SMP box with an Adaptec 7xxx-family adapter, and document the workaround (boot UP).

I will look forward to trying the 'new' driver on Wolverine when it is available (perhaps it is already?) and comment this bug with confirmation of resolution.

;-)
Comment 5 Michael K. Johnson 2001-03-12 12:54:06 EST
Dana, a known bug with this description was fixed between Fisher
and Wolverine.  Doug said "suspect" in case of the remote possibility
that there is a different bug with a similar description.

Note You need to log in before you can comment on or make changes to this bug.