This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 306881 - Needed: dovecot-devel package
Needed: dovecot-devel package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 09:00 EDT by Trever Adams
Modified: 2008-06-17 23:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 12:56:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Spec file with changes for -devel package (28.74 KB, application/octet-stream)
2007-10-02 06:56 EDT, Trever Adams
no flags Details

  None (edit)
Description Trever Adams 2007-09-26 09:00:39 EDT
There are a lot of plugins out there for dovecot. Many of these currently are
not (and due to dependencies) cannot be in Fedora. Some examples are the dspam
plugin for dovecot (learn/unlearn spam based on special folders).

Is it possible to put the headers of dovecot into a devel package in the f8 cycle?
Comment 1 Trever Adams 2007-10-02 05:55:43 EDT
Apparently, dovecot has a "--enable-headers-install" option. So, this needs to
be added to the configure options in the spec file and then the appropriate
changes to the spec file to create the package.
Comment 2 Trever Adams 2007-10-02 06:56:21 EDT
Created attachment 213281 [details]
Spec file with changes for -devel package

The devel package is currently empty due to what appears to be a bug in the
configure scripts for dovecot.
Comment 3 Tomas Janousek 2007-10-02 07:02:22 EDT
Yeah, this way of packaging is not yet supported and working even in upstream.
There was some discussion about it on the dovecot mailing list and I think we
can do it. I'll try to do it in rawhide with dovecot 1.1 and then backport it to F8.
Comment 4 Trever Adams 2008-03-28 17:03:03 EDT
Has this seen any progress?
Comment 5 Tomas Janousek 2008-03-30 07:41:38 EDT
No, no dovecot 1.1 in rawhide yet.
Comment 6 Bug Zapper 2008-05-13 23:17:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Dan Horák 2008-06-06 12:56:47 EDT
devel subpackage will land in rawhide tomorrow, if you are still interested in
F-9/F-8, let me know
Comment 9 Trever Adams 2008-06-06 19:54:58 EDT
I am still interested for F-9. I no longer have any F-8 installations.

Thank you for your work.
Comment 10 Fedora Update System 2008-06-07 07:46:12 EDT
dovecot-1.0.14-8.fc9 has been submitted as an update for Fedora 9
Comment 11 Fedora Update System 2008-06-07 07:47:25 EDT
dovecot-1.0.14-8.fc8 has been submitted as an update for Fedora 8
Comment 12 Fedora Update System 2008-06-17 23:13:36 EDT
dovecot-1.0.14-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-06-17 23:16:34 EDT
dovecot-1.0.14-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.