Bug 30694 - Use of dangerous parms for IDE disks
Use of dangerous parms for IDE disks
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 16:03 EST by jfm2
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 04:33:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jfm2 2001-03-05 16:03:05 EST
While checking with hdparms I noticed that on my machine (with a VIA Apollo
MVP3 chipset)
you were using "dma=1 unmasq_irq=1".  Unmasq_irq is supposed to be
_very_dangerous and reportedly can cause MASSIVE data corruption.  In
addition these settings are enforceed directly in the kernel since I got
them after a reboot with "noinitrd init=/bin/sh".  This makes it still more
dangerouus that if it were the result of an hdparm in the init scripts
since there will be disk activity and possibly an fsck before we have the
opportunity to turn this off.

Please don't paly russian roulette with our hard disks.
Comment 1 Arjan van de Ven 2001-03-06 04:32:55 EST
The VIA driver _ITSELF_ turns that on unconditionally; regardless of the DMA
setting. The maintainer of the driver most likely determined it was safe to do
so with his driver. If we disable this, we run the risk of more corruption as
the rest of the driver might assume it is always 1.

Note You need to log in before you can comment on or make changes to this bug.