Bug 30702 - rpm-spec-mode can't build packages in emacs
rpm-spec-mode can't build packages in emacs
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-03-05 16:33 EST by Jeremy Katz
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-08 12:00:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2001-03-05 16:33:43 EST
rpm-spec-mode uses replace-in-string which only exists in xemacs and not in
standard GNU Emacs which prevents you from using the package building bits
of rpm-spec-mode.  rpm-spec-mode should either only be installed to work
with xemacs or be fixed (I had tried an older version of rpm-spec-mode at
one point before it made it into the package and it worked fine)
Comment 1 Trond Eivind Glomsrxd 2001-03-05 17:25:43 EST
Verified. I mainlu use it for C-c e and C-c r, and hadn't noticed. Emacs 21 has
"replace-regexp-in-string", not quite sure what to use for Emacs 20. I've
notified the author.
Comment 2 Trond Eivind Glomsrxd 2001-03-07 14:47:51 EST
It's fixed in 0.11e, available from http://www.tihlde.org/~stigb/rpm-spec-mode.el

I've put together a emacs-20.7-33, which isn't yet in the tree.
Comment 3 Trond Eivind Glomsrxd 2001-03-08 11:59:59 EST
It is now.
Comment 4 Jeremy Katz 2001-03-08 12:04:03 EST
Looks good; thanks

Note You need to log in before you can comment on or make changes to this bug.