Bug 30705 - minor Xconfigurator resolution selection bug
Summary: minor Xconfigurator resolution selection bug
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-05 21:39 UTC by Panic
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 21:40:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Panic 2001-03-05 21:39:47 UTC
I almost feel bad reporting this. :)  It might be a symptom of something
that could be a problem down the road, though.

In the Xconfigurator that shipped with Wolverine, there is a minor issue
with resolution and color depth selection.  When 640x480x8 is selected and
you tab to the next area (intending to tab down to OK and move on), the
1600x1200x16 option is automagically selected as well.

Reproducible:

Always (at least on my Voodoo 3 and SN-VRXT7-WA DEC 17" monitor)

Steps to reproduce:

1. Run Xconfigurator, accept your settings until you reach the
resolution/color depth selection screen.

2. Select 640x480x8, then press tab to move to the 16-bit column -- presto,
1600x1200x16 is now selected as well.

There is definitely something squirrely going there, because if you select
the 1600x1200x16 entry and then tab back around to the 8-bit entries,
640x480 gets automagically selected again.  It only affects the 640x480x8
and 1600x1200x16 as far as I can tell.  Both entries get written to
/etc/X11/XF86Config-4, and if you test it, the 1600x1200 entry comes up if
possible.

Comment 1 Panic 2001-03-05 21:40:33 UTC
Forgot -- this is text-mode Xconfigurator running after the installation.

Comment 2 Preston Brown 2001-03-12 16:44:32 UTC
this was related to bug 28464, which I also just fixed.  Tested that this bug 
is no longer present; I squashed it. Xconfigurator 4.9.20 and later contains 
the fix.



Note You need to log in before you can comment on or make changes to this bug.