Bug 307311 - Enable Javascript support in elinks
Enable Javascript support in elinks
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: elinks (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 12:28 EDT by Toshio Ernie Kuratomi
Modified: 2008-07-02 06:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 06:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2007-09-26 12:28:50 EDT
Description of problem:
elinks is capable of linking against the js library to provide a text mode,
javascript enabled browser (not as full featured as firefox but a step in the
right direction.)  

Is there any reason not to enable this for Fedora 9?

Additional info:
Elinks Manual page for building with javascript::
  http://elinks.or.cz/documentation/html/manual.html-chunked/ch01s06.html

We're packaging SpiderMonkey as "js".
Comment 1 Ondrej Vasik 2007-12-05 08:05:34 EST
There was already discussion about that in debian. You could read it here -
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=428549 . Upstream maintainer
wrote that ECMAScript support in ELinks 0.11.1 has several bugs that can
cause SIGSEGV and that Debian shouldn't activate javascript by default for that
version. All known SIGSEGV's for javascripts are fixed in 0.12GIT, but this is
still not released as 0.12 because of some regressions. So I'm adding keywords
Future Feature - this will be not activated for elinks 0.11.3 by default, you
can easily activate it yourself if you want. 
Comment 2 Ondrej Vasik 2008-07-02 06:04:28 EDT
Today I did update to Elinks0.12pre1 in RAWHIDE. At
http://elinks.or.cz/release.html you can see that upstream recommends to disable
ECMASRIPT support by default and if necessary, to restrict elinks somehow in
sandbox to prevent possible malicious code issues. Therefore closing that
bugzilla WONTFIX, ECMAScript support will be not enabled in Fedora by default
until mentioned upstream bugzillas will be solved. As soon as the ECMAScript
support will be more safe (those bugzillas closed), I will enable the support in
Rawhide.

Note You need to log in before you can comment on or make changes to this bug.