Bug 307341 - pulseaudio causes xmms ALSA to go into 'pause' at end of each song
pulseaudio causes xmms ALSA to go into 'pause' at end of each song
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 12:40 EDT by Valdis Kletnieks
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 15:48:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2007-09-26 12:40:12 EDT
Description of problem:
When routing the audio from xmms to pulseaudio by listing 'pulse' as the audio
devide in the ALSA output plugin, the playback stops at the end of each song,
and I need to hit 'pause' to get it moving again.  Stopping pulseaudio and
configuring xmms to send to ALSA like it did before pulseaudio showed up works
correctly.  Installing the xmms-esd output plugin works, but is a phenomenal
regression.  It's bad enough that a program that *used* to be able to route to
the default ALSA device now needs to route to 'pulse' - now I need to install a
frikking *plugin*.  Why are we bothering with having ALSA installed at all, if
having a single program that actually *uses* it hoses the whole sound system?
 
Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.12.svn20070925.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lennart Poettering 2007-10-01 15:48:40 EDT
xmms is just horendously broken and makes assumptions about ALSA that are
clearly invalid.

I fixed this now in alsa-plugins 1.0.14-4. It's not a hack I am particularly
proud of. But it's a relatively clean fix, given that both xmms and alsa ioplug
are broken and essentially unmaintained.
Comment 2 Valdis Kletnieks 2007-10-02 12:16:04 EDT
Couldn't have been *that* clearly invalid an assumption about ALSA, if the bug
went un-noticed/un-fixed for years.

*THAT* bug seems fixed now, but I had the pulseaudio daemon totally evaporate on
me *again* today, just because something else managed to open the device and
pulseaudio didn't want to play nice and work in shared mode.  This would
probably work slightly better if the install of pulseaudio had tweaked the right
files so 'pulse' was the default ALSA device, but since that apparently didn't
happen, every time Firefox hits something that uses Flash or mplayer, ker-blammo. 
Comment 3 Lennart Poettering 2007-10-15 13:31:32 EDT
It is a gross misuse of the ALSA API. XMMS checks if playback stopped by waiting
for an XRUN to happen. This is so borked, I am sorry. Just because that works
most of the time it doesn't nmake it better.

Hmm, is this an upgraded system? By default we now activate the pulse plugin for
alsa by default. Also, we install libflashsupprt.so by default, which should
make Flash play nice with PA.
Comment 4 Valdis Kletnieks 2007-10-16 20:35:10 EDT
Yes, it started off with a Fedora 7 install back in December and has basically
been following Rawhide ever since, so it's quite possible that 'yum update' has
failed to suck in some RPM that should have been pulled in.

Yep, no libflashsupprt.so here:

% locate libflash
/home/valdis/.mozilla/plugins/libflashplayer.so
/home/valdis/install_flash_player_7_linux/libflashplayer.so
/home/valdis/install_flash_player_9_linux/libflashplayer.so
/usr/lib64/openoffice.org/program/libflash680lx.so

And what needs to be done to activate pulse in alsa 'by default'?  I'm certainly
not seeing the appropriate script-fu in 'rpm -q --scripts pulseaudio' (it adds
the user/group, but doesn't fix /etc/alsa/alsa.conf.
Comment 5 Valdis Kletnieks 2007-10-16 20:37:32 EDT
"repoquery --whatprovides libflashsupprt.so" comes up empty - this would be
easier to figure out if the appropriate RPM had a Provides: attached to it?
Comment 6 Lennart Poettering 2007-10-17 14:58:32 EDT
Because of evil multilib libflashsupport.so had to be split off into a seperate
package.

sudo yum install libflashsupport

Note You need to log in before you can comment on or make changes to this bug.