Bug 307371 - Prod-only 404 Error on /rhn/users/AssignedSystemGroups.do
Prod-only 404 Error on /rhn/users/AssignedSystemGroups.do
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
high Severity high
: ---
: ---
Assigned To: Grant Gainey
Mike Orazi
:
: 371651 (view as bug list)
Depends On:
Blocks: 253918
  Show dependency treegraph
 
Reported: 2007-09-26 12:59 EDT by Máirín Duffy
Modified: 2010-10-22 14:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 09:36:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2007-09-26 12:59:39 EDT
Description of problem:

This may be related to 503 bug 249620.

Customer account is hitting a 404 error on the Users > User Details > System
Groups page when using the filter box. Steps to reproduce the error:

1: top red nav bar Users tab
2: click on a user's name to view their details
3: click on the user details 'system groups' tab
3: use the Filter by Username filterbox in the listview of system groups
4: encounter 404 error.

We tried to reproduce this error in webqa with no luck. morazi has reproduced in
prod with another account. URL to follow in a private comment.
Comment 11 Grant Gainey 2007-10-30 12:52:49 EDT
The issue is the result of a poor choice in the JSP implementation.  The
failure-mode only bites us for customers with significant numbers of
system-groups, and only in PROD because only there does the sizable (incorrect)
URL being built collide with rules at the proxy layer.

More testing required, but this fix will be part of the 504 BZ stream.
Comment 16 Grant Gainey 2007-11-08 13:58:29 EST
off to dev with you
Comment 17 Grant Gainey 2007-11-08 14:11:50 EST
*** Bug 371651 has been marked as a duplicate of this bug. ***
Comment 18 Grant Gainey 2007-11-09 07:52:32 EST
Final QA push
Comment 19 Grant Gainey 2007-11-09 07:53:47 EST
No, really - ON_QA

Note You need to log in before you can comment on or make changes to this bug.