Bug 30743 - Big Old Bucket O' Badness on AMD Duron
Big Old Bucket O' Badness on AMD Duron
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 21:27 EST by Dan Morrill
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 23:56:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Morrill 2001-03-05 21:27:34 EST
Where to begin?  RH 7.1 beta 2 appears to have significant issues on
AMD Duron systems.  (Or at least the AMD Duron/Tyan S2390 combo I
have.)

First, anaconda as shipped with Wolverine has issues crashes regularly
on my system, either not installing the kernel (i.e. not completing
the install) or installing a corrupt kernel.  However, this is fixed
in the Rawhide boot disks, so there is no need for a bug for this.

Second, the 2.4.1-0.1.9 kernel as installed by default on Wolverine
appears to have severe problems with the Duron.  It generates spurious
SIGSEGVs, corrupts downloads (i.e. MD5 checksum errors), and scrambles
the filesystem.  This points to either a hardware problem (bad CPU, RAM,
or motherboard) or a kernel problem on the Duron.

RH 6.2 upgraded to kernel 2.4.2 (stock) does NOT exhibit these problems,
so it seems like a kernel thing vs. a hardware thing. Upgrading Wolverine
to 2.4.2, and switching from the i686 glibc to the i386 glibc appears to
have fixed Wolverine.  In other words, I think this is fixed, if you
tweak it enough.


Solution:
- upgrade the kernel to 2.4.2 before release
- on Duron systems (detect during install?) do NOT install the i686
  glibc, but rather the i386 glibc.  Maybe just offer the user a
  choice?  ("Install for compatibility" vs. "Install for performance";
  "Choose compatibility if you have problems with a performance install.")
Comment 1 Glen Foster 2001-03-06 15:20:34 EST
Re-assigning to kernel
Comment 2 Arjan van de Ven 2001-03-07 03:33:03 EST
Could you try our latest 2.4.2 based kernel available through up2date and
in rawhide ?
Comment 3 Dan Morrill 2001-03-07 23:55:56 EST
I did a lateral upgrade from my 2.4.2 to the Rawhide 2.4.2, and both appear to 
work perfectly fine.  I also switched back to the i686 glibc from the i386 
glibc, and still no problems (so far.)

Linus' changelog for 2.4.1 -> 2.4.2 cites a "serious" IDE driver bugfix;  he 
said it was only seen on ARM, but it seems possible that the Duron could also 
expose the bug through idiosyncracies in its cache behavior, etc.

It seems increasingly probable that this was a kernel bug up through 2.4.1 
that is fixed in 2.4.2.  (I assume the rawhide kernel is still optimized for 
i686 and not Athlon/Duron/K7 right? So it's probably not that.) This bug can 
probably be closed, and I will resurrect if it self-destructs again. :)
Comment 4 Arjan van de Ven 2001-03-08 04:01:07 EST
Thanks for testing. Our rawhide 2.4.2 kernel contains some workarounds for
chipsetbugs that cause corruption on VIA chipsets. I'm glad either this or the
generic 2.4.2 code fixed it.

Our i686 kernels are indeed Pentium II optimized, but you can make an 
Athlon specific kernel yourself by doing

rpm --rebuild --target=athlon  kernel-2.4.2-0.1.XX.src.rpm

(closing this bug as fixed in rawhide)

Note You need to log in before you can comment on or make changes to this bug.