Bug 307571 - Update request: libtheora-1.0beta1
Update request: libtheora-1.0beta1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libtheora (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
http://www.theora.org/news/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 14:09 EDT by Michel Alexandre Salim
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 08:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2007-09-26 14:09:48 EDT
Description of problem:
Theora 1.0beta1 was released a few days ago. From the release announcement, it
seems that it will be a good idea to update -- the bitstream has changed, but
the new decoder can handle all previous versions.

Version-Release number of selected component (if applicable):
libtheora-1.0alpha8-0.3.svn13393
Comment 1 Hans de Goede 2007-10-08 03:28:55 EDT
Behdad,

I think upgrading is a good idea, as we are now using a svn snapshot. I
especially think upgrading is a good idea because of this mail I just received
from upstream:
---
Greetings. I observed your name in the Theora RPM in Fedora as the
most recent person to change the package.

Fedora 8 Test 3 appears to have 1.0alpha8-0.1.svn13393. Theora 1.0
beta is now out (Announcement
http://lists.xiph.org/pipermail/theora/2007-September/001595.html).

It's believed that the current SVN snapshot in Fedora came from a time
when the theora tree was fairly buggy, though perhaps you managed to
select a golden version.

Is there any chance of getting the more recent theora code into Fedora 8?
---

So since upstream is requesting us to fix this (and rightfully so) shall I
create a new package and submit that to rawhide and F-7 updates-testing?
Comment 2 Behdad Esfahbod 2007-10-11 00:20:47 EDT
Hans,

Please feel free to update as you feel the need.  In fact, feel free to take
ownership of the package; or the entire vorbis stack FWIW.  Thanks.
Comment 3 Hans de Goede 2007-10-11 08:27:27 EDT
Updated, tested and build for rawhide. F-7 version is building and I'll push
that to updates-testing once its done.

About taking owner ship of the vorbis stack, I'll request the necessary rights
in packagedb to be able to co-maintain it and I'll try to do most of the work,
first lets try that for a while, if that works well and you would like to
officially unown it thats fine with me.

Note You need to log in before you can comment on or make changes to this bug.