Bug 30772 - pump does not set hostname
pump does not set hostname
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-03-06 01:23 EST by Tommy McNeely
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-16 09:38:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
pump and dhcpcd information (6.54 KB, text/plain)
2001-03-07 02:02 EST, sandy
no flags Details
good pump and dhcpcd information (6.72 KB, text/plain)
2001-03-07 02:07 EST, sandy
no flags Details

  None (edit)
Description Tommy McNeely 2001-03-06 01:23:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-CCK-MCD Netscape [en] (X11; U; SunOS 5.8 sun4u)

In redhat 7.0, if my hostname on my laptop was set to
"localhost.localdomain" the pump program would set my hostname to whatever
was proper for the current connection (be it at work or at home) to include
hostname and domainname. however, in this wolverine release, it seems to
stay as localhost??

Reproducible: Always
Steps to Reproduce:
1. set hostname to localhost.localdomain
2. setup DHCP server to give me a known address
3. setup forward and reverse dns
4. boot laptop
5. login screen says "Welcome to localhost.localdomain"

Actual Results:  login screen says "Welcome to localhost.localdomain"

Expected Results:  login screen says "Welcome to bongohead.Central.Sun.COM"

or if at home "Welcome to bongohead.local.redneck.nu"

I have tried 'service network restart' and had limited success, but now its
not working at all.. I have added a check in the ifup script to make sure
it was working

echo $PUMPARGS > /pumpargs

and I get "--lookup-hostname"
(which is correct)

Not sure why its not working properly.
Comment 1 Tommy McNeely 2001-03-06 01:25:43 EST
knop@sunray5:~$ nslookup bongohead
Server:  geb.Central.Sun.COM

Name:    bongohead.Central.Sun.COM

knop@sunray5:~$ nslookup
Server:  geb.Central.Sun.COM

Name:    bongohead.Central.Sun.COM

Comment 2 Tommy McNeely 2001-03-06 01:50:27 EST
ok... here's some more stuff... then I gotta go home :)

It is now re-producable...

- Boot laptop (with network configured as before)..
- login screen says localhost
- login as root (to the console tty1) and /etc/init.d/network restart
- go back to the X screen and restart the X server (CTRL-ALT-BKSPC)
- it goes to a grey screen with a X mouse
- a little whil later gdm dies and takes the X server with it.

I presume it has something to do with the "depreciation" of nslookup..  or else
there is some sort of other name resolution problem...

I tried entering the network restart comand from within X, and could not even
log out...

 I will play more with this tomorrow... 

If there are any suggestions, I would be glad to try them (I work the night

TJ McNeely
Sun Microsystems - Resolution Center Americas
Comment 3 Glen Foster 2001-03-06 15:24:22 EST
We've had a heckuva time reproducing defects like this here in NC.  How
reproducible is this bug and would you be willing to reproduce remotely for us? 
We'd REALLY like to fix this...
Comment 4 sandy 2001-03-07 02:02:02 EST
Created attachment 11982 [details]
pump and dhcpcd information
Comment 5 sandy 2001-03-07 02:06:19 EST
Please ignore last attachment.

I have a similar problem with pump.  I get no hostname assigned.
However, if I move /sbin/pump so that ifup uses dhcpcd instead
I do get a hostname.  But I get two dhcpcd clients started?

See following attachment
Comment 6 sandy 2001-03-07 02:07:46 EST
Created attachment 11983 [details]
good pump and dhcpcd information
Comment 7 Tommy McNeely 2001-03-21 22:43:01 EST

I would have responded sooner... but it appears I do not recieve updates to this
ticket in email?? or i lost it.. whatever..

I was able to reproduce it everytime... however, right now my machine is
statically assigned and is actually bound to NIS... btw, kudos to the folks that
made all this stuff work with 32bit UID's :)

I can do whatever you want to try to reproduce it.. I just noticed that up2date
actually works in the beta release... albeit kinda slow right now, I will do a
fresh install on my laptop (to be sure all my little nis tweaks dont interfere)
and run all updates... then try it again..  and let you know. It will not be
possible for you to login to my laptop on the network.. (damn firewall) but I am
pretty handy in linux.. and can probably get you whatever you request...

Since I dont seem to be getting updates.. if you could cc TJ.McNeely@Sun.com
when you add a note it would be handy.

TJ McNeely
Sun Microsystems
Comment 8 Eugene Kanter 2001-04-06 12:04:32 EDT
I do not remember how wolverine behaved but post wolverine QA releases, 
including 0404 seems to set the hostname using reverse DNS, if available. If 
not available, it defaults to localhost.
Comment 9 Tommy McNeely 2001-04-06 17:10:51 EDT
I thought I added this note already...

The updated PUMP package (now that update agent works again) fixes the problem..
I have verified it twice. The pump package that comes on the wolverine CD seems
to be the problem.. So long as the new pump package is released with FCS there
should be no problems.

TJ McNeely
Sun Microsystems
Comment 10 Tommy McNeely 2001-04-10 16:06:51 EDT
issue is resolved by updated pump package - currently version pump-0.8.11-1

Tj McNeely
Sun Microsystems
Comment 11 ajs 2001-04-20 18:12:38 EDT
I did not encounter this problem when my client machine was running Wolverine,
but now that the DHCP server is running Seawolf it suddenly shows up.  I have
two client machines; one running Wolverine, one running Seawolf.  When the
server was running Guinness everything was OK, but as soon as it was upgraded to
Seawolf pump would not set the hostname.  If I change to dhcpcd, however,
everything works.

Comment 12 Tommy McNeely 2001-04-20 18:19:53 EDT
I am using Solaris DHCP/DNS/etc servers.. my seawolf laptop and desktop both are
obtaining hostnames correctly. and with a quick tweak to the /etc/auto.master
file, this is a totally viable desktop (it binds to NIS, mounts my home dir, and
participates like a champ :))

TJ McNeely
Sun Microsystems - RC Americas
Comment 13 Elliot Lee 2001-08-26 17:45:46 EDT
Sounds like the bug has been fixed a long time ago - closing!

Note You need to log in before you can comment on or make changes to this bug.