Bug 30798 - NEC ATAPI ZIP drive problem
NEC ATAPI ZIP drive problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-06 06:02 EST by Péter, Soós
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 06:03:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Péter, Soós 2001-03-06 06:02:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


We use RedHat Linux with kernel 2.2.x. We have some ZIP drives (paralell,
SCSI, IDE, ATAPI), but we have a problem the ATAPI ones. If I partitioned a
ZIP disk in the SCSI os paralell or IDE drives, all drives can read and
write this diskette, but the ATAPI ones (NEC FZ110A) can't read them. It is
interesting that an original Iomega ATAPI drive has no this problem.
The symptom is the following with a pre-partitioned disk:

# fdisk /dev/hdb
hdb: The drive reports both 100663296 and 100646912 bytes as its capacity
Device contains neither a valid DOS partition table, nor Sun or SGI
disklabel
Building a new DOS disklabel. Changes will remain in memory only,
until you decide to write them. After that, of course, the previous
content won't be recoverable.
Command (m for help): p

Disk /dev/hdb: 64 heads, 32 sectors, 96 cylinders
Units = cylinders of 2048 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System

Command (m for help): q

#

Reproducible: Always
Steps to Reproduce:
1. Partition and format a disk in a SCSI or paralell ZIP drive
2. Try to read it in NEC ATAPI Zip drive
Comment 1 Péter, Soós 2001-03-22 05:28:18 EST
The problem is solved. You have to remove the jumper 3 from the drive (e.g. use
it as Slave mode without jumper (Slave) instead Slave mode with jumper (Slave
A). See:
http://147.178.1.118/eshare/server?action=190&PAGE=1&ASORT=3&BSORT=1&BOARD=18&ARTICLE=7825&AEXPAND=&BEXPAND=&EXPANDFULLY=0&EXPANDBRANCH=0

Note You need to log in before you can comment on or make changes to this bug.