Bug 308201 - rtl8139 NIC doesn't work in Windows Vista
rtl8139 NIC doesn't work in Windows Vista
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 19:18 EDT by Max Kanat-Alexander
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 35-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-06 20:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix checksum for Vista (1.51 KB, patch)
2007-09-26 19:37 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Max Kanat-Alexander 2007-09-26 19:18:34 EDT
libvirt hardcodes the "nic" parameter to qemu, but Vista needs a different
"model" argument, as described here:

http://kvm.qumranet.com/kvmwiki/Vista_Networking_Workaround?highlight=%28vista%29

When I modify the qemu_conf.c to add that model line, networking works in Vista.

This is a problem at least as of libvirt-0.3.2-1.fc7, qemu 0.9.0-2.fc7, and
kvm-35-2.fc7.
Comment 1 Daniel Berrange 2007-09-26 19:34:17 EDT
No, modifying the libvirt driver to hardcode it to ne2k is not an acceptable
change because it breaks other OS for which rtl8139 *is* the best choice. ie all
Linux guests. The correct solution is to fix the RTL8139 driver in QEMU/KVM.

IIRC there were recently some fixes applied to upstream QEMU specifically for
Vista support. I'll try and find them so we can fix the real problem rather than
hacking around it.
Comment 2 Daniel Berrange 2007-09-26 19:37:40 EDT
Created attachment 207741 [details]
Fix checksum for Vista

Attaching the patch from upstream

http://www.mail-archive.com/qemu-devel@nongnu.org/msg11365.html
Comment 3 Daniel Berrange 2007-09-26 20:12:58 EDT
Please re-test with either the i386 or x86_64 experimental KVM  RPM builds I've
done containing the patch from comment #2:

x86_64  http://koji.fedoraproject.org/koji/taskinfo?taskID=176240
i386    http://koji.fedoraproject.org/koji/taskinfo?taskID=176241


If it works with Vista's RTL8139 driver, I'll apply to the real build in Fedora
updates.
Comment 4 Max Kanat-Alexander 2007-09-26 21:19:40 EDT
Yes, that fixes it on my x86_64 machine. :-) Thank you.
Comment 5 Daniel Berrange 2007-09-26 23:23:14 EDT
Submitted kvm-35-3.fc7 to F-7 updates-testing with the fix.
Comment 6 Daniel Berrange 2007-09-26 23:48:22 EDT
Also submitted qemu-0.9.0-3.fc7 to updates-testing, and both kvm & qemu to
rawhide, and queued fixed for Xen.
Comment 7 Fedora Update System 2007-09-28 17:19:48 EDT
kvm-35-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2007-09-28 17:19:53 EDT
qemu-0.9.0-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2007-10-03 17:11:58 EDT
kvm-35-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2007-10-03 17:12:04 EDT
qemu-0.9.0-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Max Kanat-Alexander 2007-10-06 20:24:59 EDT
Okay, it looks as though the problem actually still persists. 

I accidentally thought things worked, but they don't, it seems. I can't get a
DHCP response inside a Vista VM, and with a static IP I can't ping my router (I
get Destination Host Unreachable).
Comment 12 Max Kanat-Alexander 2007-10-06 20:27:09 EDT
Oh, wait, I'm sorry. It was just an iptables problem--I forget every time I
start the VM that I have to disable iptables because I'm using a physical bridge.

Note You need to log in before you can comment on or make changes to this bug.