Bug 30827 - wrong default color depth
Summary: wrong default color depth
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-06 17:24 UTC by Gerald Teschl
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 17:50:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-03-06 17:24:15 UTC
If I set up my vide card and choose only "1024x768 @ 24 bpp", Xconfigurator
will
write display sections for both 24 bpp and 32 bpp plus it will add

DefaultColorDepth 32

hence X will use 32 bpp and fail since 32 bpp is not supported by my card.
BTW it does not offer 32 bpp in the list of available modes.

Comment 1 Bill Nottingham 2001-03-06 19:24:46 UTC
What card?

Comment 2 Glen Foster 2001-03-06 21:12:50 UTC
This defect considered MUST-FIX (show-stopper) for Florence GOLD release.

Comment 3 Gerald Teschl 2001-03-07 09:14:45 UTC
00:02.0 VGA compatible controller: Silicon Motion, Inc. SM910 (rev b5)
00:02.0 Class 0300: 126f:0910 (rev b5)

Comment 4 Bill Nottingham 2001-03-08 23:29:51 UTC
I can't reproduce this here; if I try to configure a Silicon Motion card
and select only 1024x768 @ 24bpp, that's all it writes out.

This is Xconfigurator that does this and not the installer, correct?
What version of Xconfigurator do you have installed?

Comment 5 Gerald Teschl 2001-03-09 10:47:28 UTC
Just tried it again. Works now.

[gerald@soliton gerald]$ rpm -q Xconfigurator
Xconfigurator-4.9.16-1

Comment 6 Gerald Teschl 2001-03-09 17:16:03 UTC
Sorry, in my previous test no XF86Config was written at all. I tested it again
and it still
happens under Xconfigurator-4.9.18-1.

Comment 7 Bill Nottingham 2001-03-09 17:26:39 UTC
Oh, ok. The 32bpp is written for XFree3, not XFree4. Out of curiousity,
does the XFree4 driver work?

Comment 8 Bill Nottingham 2001-03-09 17:50:07 UTC
Will be fixed in 4.9.19-1.


Note You need to log in before you can comment on or make changes to this bug.