Bug 30828 - ks installation: hsync/vsync
ks installation: hsync/vsync
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-06 12:32 EST by Gerald Teschl
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 15:22:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-03-06 12:32:47 EST
I used the line

xconfig --startxonboot --hsync "31-60" --vsync "50-80"

in my ks.cfg file but got

    HorizSync   35.15
    VertRefresh 55-65

in XF86Config!? Moreover, it did only set up
-----------------------------
    DefaultColorDepth 16

    Subsection "Display"
        Depth       16
        Modes       "800x600" 
        ViewPort    0 0
    EndSubsection
-------------------------------

Is there a way of specifying the mode/depth in the ks.cfg file?
Comment 1 Brent Fox 2001-03-06 15:18:48 EST
According to the kickstart documentation, there is currently no way to specify
color depth through kickstart.  Not a bad idea, though, for future development.

I'm looking into the sync rates problem.
Comment 2 Brent Fox 2001-03-06 15:43:25 EST
The sync problem appears in RHL 7.0 too, so this issue isn't new.
Comment 3 Brent Fox 2001-03-06 16:19:15 EST
Wait a minute...this did work in 7.0.  I tested against the wrong version.
Comment 4 Brent Fox 2001-03-06 16:43:35 EST
Actually, this works in Wolverine.  Here's the line from ks.cfg:
xconfig --startxonboot --hsync "31-60" --vsync "50-80"

And here's the output in XF86Config-4
HorizSync    31-60
VertRefresh  50-80
Comment 5 Gerald Teschl 2001-03-07 04:21:00 EST
(1) If the installer only sets up 800x600 the xconfiguration is useless!!!!! I
guess most people will
want to have at least 1024x768 these days!

(2) I am not talking about XF86Config-4, I am talking about XF86Config! My card
still uses
the 3.3.6 server.
Comment 6 Gerald Teschl 2001-03-07 04:21:42 EST
Forgot to mention, this applies to rc2.
Comment 7 Brent Fox 2001-03-07 11:07:33 EST
Ok, here's my XF86Config...

Section "Monitor"

    Identifier  "DELL P991"
    VendorName  "Unknown"
    ModelName   "Unknown"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    HorizSync   31 - 60

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    VertRefresh 50 - 80


The code that writes out the XF86Config and XF86Config-4 files share the same
variables...so the refresh rates will be the same in the two files.

What kind of video card do you have?  It's possible that the problem appears if
the installer can't identify your video card.
Comment 8 Gerald Teschl 2001-03-09 05:51:40 EST
00:02.0 VGA compatible controller: Silicon Motion, Inc. SM910 (rev b5)

The installer detects the card and chooses the right server. But I guess it
cannot dedect
the monitor: LCD panel.

Comment 9 Michael Fulbright 2001-03-09 11:06:48 EST
It looks like the failure mode is to use the supplied values in the ks.cfg file
if the monitor probe failed.

Take a look at this Brent.
Comment 10 Michael Fulbright 2001-03-20 12:24:19 EST
Any ideas on this Brent?
Comment 11 Brent Fox 2001-03-20 15:22:27 EST
I'll try to get an LCD and test today.
Comment 12 Brent Fox 2001-03-20 16:02:59 EST
This works correctly in the qa0320.0 tree. This issue is resolved.

Note You need to log in before you can comment on or make changes to this bug.