Bug 30831 - X hangs when beacuse agpgart is no loaded properly with, i815 chipset with Nvidia Geforce external graphic card
X hangs when beacuse agpgart is no loaded properly with, i815 chipset with Nv...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-06 13:13 EST by Knut J BJuland
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 14:24:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2001-03-06 13:13:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.19 i686)


When I am using Nvdia driver 0.9-6 it can not run with i815 chipset. But
when I start linux with linux single and modprobe agpgart, I can run
XFree86 with opengl hw.

Reproducible: Always
Steps to Reproduce:
1.start the machine without modprobe agpgart and X hangs
2.
3.
	

Actual Results:  X hangs.

Expected Results:  I would expect X to run

I have a DELL with i815 mothercard from intel, nvidia geforce 2 gts. My
system work perfectly with linux-2.4.2-ac10 without any trouble. I have
here not compile in 810 agp support but i815/440BX etc support
Comment 1 Bill Nottingham 2001-03-06 14:23:45 EST
This should be fixed in the next XFree86 build, although we do not
support the nVidia drivers.
Comment 2 Mike A. Harris 2001-03-07 05:46:49 EST
The agpgart thing is fixed now, and as an added bonus - Mark
Vojcovich just updated the XFree86 nvidia drivers for 4.0.2 quite
a bit fixing lots of outstanding issues with these cards.  I will
be incorporating these into a build RSN.  Hopefully nvidia cards
won't be left in the dark anymore.

For the agpgart fix, get XFree86-4.0.2-11.4.0 from:

ftp://people.redhat.com/mharris/xfree86
Comment 3 Knut J BJuland 2001-03-08 04:06:05 EST
Agpgart fix does not cause agpgart to load when using Nvidia driver 0.9-6.
Perhap you should add modprobe agpgart to startup script to force agpgart to
load. I made Nvidia 0.9-6 to load by insertin /sbin/modprobe agpgart in statup
script. I think Redhat should include Nvidia 0.9-6 in RedHat 7.1 to enable 3D hw
support with Nvidia.
Comment 4 Mike A. Harris 2001-03-08 04:43:53 EST
Absolutely not - on all counts.  I personally don't care if the proprietary
Nvidia driver works at all.  If I could, I would build the X server to
not allow separate binary modules to be loaded at all.

Why?  Because I cannot in any way shape or form do anything to fix nvidia's
binary driver as I do not have source.  Since I do not have source, and can
not fix bugs in it, I don't care about the bugs period.  Email nvidia for
support for their bugs.  As for agpgart not loading on this driver, all I can
say is "use the Xfree86 nv driver".  It is XFree's job to load agpgart, and
it is currently doing so perfectly on all test systems using open source
drivers, so as far as I'm concerned, the nvidia proprietary driver is buggy,
and the fix is up to them.

Fortunately, as I stated in my last comment, Mark from nvidia has updated
the nv opensource driver to fix a bunch of bugs.  This is cool, and I will
be adding this stuff in very soon.  Hopefully it fixes any trouble, if not,
then all nvidia users will have to wait until nvidia does in fact fix the
bugs.  Mark is a good guy, and was recently hired there, so perhaps this is
a good sign that nvidia might be waking up to smell the maple nut crunch.

In general however, my advice to nvidia owners that have problems with the
nv driver, and the nvidia driver, is "buy an ATI Radeon, they smoke."
;o)

Note You need to log in before you can comment on or make changes to this bug.