Bug 308311 - No easy way to select keyboard layout
No easy way to select keyboard layout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Desktop, Reopened
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-09-26 22:45 EDT by Lauri Nurmi
Modified: 2013-01-09 23:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-29 19:41:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 521100 None None None Never

  None (edit)
Description Lauri Nurmi 2007-09-26 22:45:04 EDT
Description of problem:
One can easily select the preferred language at the GDM login screen, but this
selection does not reflect to the active keyboard layout.

Selecting an alternative layout through the preferences requires dozens of mouse
clicks even if you knew where to look for.  There should be an easier way.

Actually, starting the "Install to hard disk" option does provide an easy way to
select the layout at the begin, but if you didn't intend to install, you don't
happen to think of it.

I'd guess the majority of Fedora users have a keyboard with a non-US layout.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start the Live-CD
2. Enjoy US keyboard layout
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Maximilian Imgrund 2008-03-29 07:19:54 EDT
I don't know if I should file another bug, but additionally, when installing
with the normal Istall DVD x86_64, I selected German keyboard layout. Setting
passwords in firstboot/anaconda works with the qwertz-layout, but gdm uses a
qwerty-layout. Thus people not aware of qwerty who have set a pass with special
chars can't even login to change layout settings. (yes, console works, but is
not the easy way) 
Comment 2 Matthias Clasen 2008-05-05 13:51:14 EDT
I've just committed keyboard selection capabilities to rawhide gdm. 
Comment 3 Lauri Nurmi 2008-08-29 19:23:06 EDT
I'm testing F10 alpha Live CD, and there is a keyboard selection box at the bottom, but it is disabled (greyed out), and stays that way no matter what language I choose.

I'm re-opening the bug, because I still don't see an easy way (nor even a hard way) to select the keyboard layout using GDM.
Comment 4 Ray Strode [halfline] 2008-08-29 19:41:39 EDT
This was broken in the alpha but fixed in rawhide shortly afterward i believe.

Note You need to log in before you can comment on or make changes to this bug.