Bug 30834 - The Installer Crashed in isys.py, fsSpaceAvailable:
The Installer Crashed in isys.py, fsSpaceAvailable:
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-03-06 13:44 EST by Martin Pabst
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-06 13:47:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
bugreport from installer (979 bytes, text/plain)
2001-03-06 13:47 EST, Martin Pabst
no flags Details

  None (edit)
Description Martin Pabst 2001-03-06 13:44:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (WinNT; U)

It is not possible to install RedHat; installation fails with error "No such file or directory'. 
The problem is independent of HD partitions and of the HW.
There is no means to solve the problem. It's quite time consuming to
reproduce the bug (prepare the installation).
The installer trace is listed below.

Reproducible: Always
Steps to Reproduce:
1.Start custom installation of RedHat; partition HD
2.Chose HW and SW configuration
3.Start the installation

Actual Results:  Bug report:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//dosc

ToDo object:


Expected Results:  Installation o.k.

The installation was o.k. on one host; it failed repeatedly on two different
hosts. The problem is high - installation impossible.

The problem may be related to bug #22302
Comment 1 Martin Pabst 2001-03-06 13:47:01 EST
Created attachment 11902 [details]
bugreport from installer
Comment 2 Daniel Roesen 2001-03-06 14:00:14 EST
See: http://www.redhat.com/support/errata/RHBA-2000-084.html

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.