This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 30851 - Installer Crashed when attempting to read package info
Installer Crashed when attempting to read package info
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-06 14:58 EST by 9 Net Avenue Deutschland
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 15:25:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description 9 Net Avenue Deutschland 2001-03-06 14:58:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)


Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in 
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/network_gui.py", line 
177, in getScreen
    label.set_alignment (0.0, 0.5)
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2193, in 
set_alignment
    _gtk.gtk_misc_set_alignment(self._o, xa, ya)
SystemError: bad argument to internal function

Local variables in innermost frame:
xa: 0.0
self: <gtk.GtkLabel instance at 84ffb70>
ya: 0.5

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Reproducible: Always
Steps to Reproduce:
1.Run Setup from diskette
2. Load CD Rom
3. Bug always occurs when it attempts to read packages
	

Actual Results:  The bug window opens with the info inserted above into 
description

Expected Results:  to install RedHat without crashing

The system has two UW160 Harddrives, and we were also attempting to 
install RAID 1 partitions.  The same bug occurs without using RAID1 
(standard partitions)
Comment 1 Michael Fulbright 2001-03-06 15:04:42 EST
Please check VC3 and VC4 (cntl-alt-f3 and -f4) when this occurs to see if there
are any read errors reported.

This has to be because of a bad CD.
Comment 2 9 Net Avenue Deutschland 2001-03-06 15:25:09 EST
I do not believe it is the CD ROM.  We have used the CD to update or install 
other systems.  It does read the CDROM to load the SCSI Drivers for the Adaptec 
160 Card.

I attempted to check VC3 and VC4, but before I could capture anything, the 
system rebooted (this time the bugzilla window did not open).
Comment 3 9 Net Avenue Deutschland 2001-03-08 04:09:39 EST
Problem was with Controller Card.  SORRY!

Note You need to log in before you can comment on or make changes to this bug.