Bug 308541 - Buttons of Adobe flash demo unresponsive when rendered by Gnash plugin 0.8.1
Buttons of Adobe flash demo unresponsive when rendered by Gnash plugin 0.8.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnash (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 04:17 EDT by Joachim Frieben
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 18:25:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adobe flash demo rendered by gnash-plugin-0.8.1-5.fc8 (27.17 KB, image/png)
2007-09-27 04:17 EDT, Joachim Frieben
no flags Details
Adobe flash demo rendered by gnash-plugin 0.8.1 compiled from sources with ogl rendering (8.60 KB, image/png)
2007-09-27 04:21 EDT, Joachim Frieben
no flags Details
xsession-errors related to rendering of Adobe flash demo (1.69 KB, text/plain)
2007-09-27 04:53 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2007-09-27 04:17:16 EDT
Description of problem:
When pointing browser 'epiphany-2.20.0-1.fc8' to the Adobe flash demo at
http://www.adobe.com/shockwave/welcome, then section 'Adobe Flash Player'
is rendered correctly but it doesn't react to a mouse pointer moving
across the respective buttons. Moreover, after moving another window
across the flash demo, only a grey rectangle is left behind. It doesn't
get refreshed, and one has to reload the entire page to see the flash
demo again.

Version-Release number of selected component (if applicable):
gnash-0.8.1-5.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Install gnash-plugin-0.8.1-5.fc8.
2. Launch 'epiphany' browser.
3. Open http://www.adobe.com/shockwave/welcome
  
Actual results:
Section 'Adobe Flash Player' is rendered correctly but unresponsive.

Expected results:
Flash demo should respond when moving mouse pointer e.g. to the 'About'
button for which one expects the version to be displayed.

Additional info:
Yesterday, I had built the Gnash plugin from the pristine source choosing
the 'ogl' renderer instead of the 'agg' one used by the Fedora package.
Font rendering quality was poor but the buttons of the flash demo worked
correctly as demonstrated by the attached screenshot.
Comment 1 Joachim Frieben 2007-09-27 04:17:16 EDT
Created attachment 207911 [details]
Adobe flash demo rendered by gnash-plugin-0.8.1-5.fc8
Comment 2 Joachim Frieben 2007-09-27 04:21:02 EDT
Created attachment 207931 [details]
Adobe flash demo rendered by gnash-plugin 0.8.1 compiled from sources with ogl rendering
Comment 3 Joachim Frieben 2007-09-27 04:53:57 EDT
Created attachment 207961 [details]
xsession-errors related to rendering of Adobe flash demo
Comment 4 Joachim Frieben 2007-10-03 18:25:41 EDT
As of 2007-10-03, the issue is not present anymore. It looks as if some of the
recent updates has solved this issue.

Note You need to log in before you can comment on or make changes to this bug.