Bug 30857 - (G450) xinerama extenstion missing (4.0.2-11.4.0)?
(G450) xinerama extenstion missing (4.0.2-11.4.0)?
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-06 15:39 EST by Michal Jaegermann
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-18 15:07:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-03-06 15:39:13 EST
With XFree86-4.0.2-11.4.0 attempts to use xinerama on G400 (with x86)
and G450 (with Alpha) graphics cards seem to go through motions but
ultimately fail:

...
(++) Xinerama: enabled
...
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
        compiled for 4.0.2a, module version = 1.0.0
...
Xlib:  extension "XINERAMA" missing on display ":0.0".

Is xinerama just not compiled in these binaries?
Comment 1 Mike A. Harris 2001-03-07 08:15:22 EST
I'm not sure.  I've got both a g450 and a g400 here.  I haven't tried the
g400 yet, but I understand from David Dawes that the dualhead doesn't work
properly.  G450 doesn't work dualhead yet, nor with dri.  These issues are
being addressed with relative high priority though.  I can't promise
anything on the Alpha, but we might possibly see a fix for some of these
issues at least on x86 soon.  I'm awaiting driver updates from Matrox...
Comment 2 Michal Jaegermann 2001-03-07 11:29:54 EST
"dualhead" and "xinerama" are not exactly the same thing (even if they both
use two monitors).  In the first case you have two separate displays, and in
the second one display but stretched across two monitors.

Yes, indeed, dualhead does not work properly yet with XFree86 and without
extra (binary only and x86) modules from Matrox.  Note that even if one will
try these Matrox modules, and dualhead works without any problems, one will
get the same response, i.e. "Xlib: .... missing ..." if attempting to turn
on xinerama.
Comment 3 Michal Jaegermann 2001-03-07 16:13:48 EST
An error message is the same on x86 with ATI R128 card; although this is
not a card with double outputs so I do not now if this may even work there
(two cards?).
Comment 4 Mike A. Harris 2001-05-15 06:04:40 EDT
Xinerama support is built into our XFree86 releases and works for me during
testing.
Comment 5 Michal Jaegermann 2001-05-19 20:51:37 EDT
In what sense "works"?  I just tried 4.0.3-15 on x86 machine with G400
card and I have the same effect as before.  That means that log files
indicate that everything is ok if I use xinerama or two screens; only I
have a blank screen when a monitor is hooked up to the second output.
When in the past I tried Matrox binary modules I had not only happy logs
but also a picture on both screens.

Note You need to log in before you can comment on or make changes to this bug.